summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1998-04-24 21:26:32 (GMT)
committerRobb Matzke <matzke@llnl.gov>1998-04-24 21:26:32 (GMT)
commit4dcf59ae4461eec74a180d77783d9064d2aa3a58 (patch)
tree3c720b6ce64b7e81e6e28f773755fe0fb97cfde9 /configure.in
parent98b5a7f9c5a881c849cd536579bb121cf185e2db (diff)
downloadhdf5-4dcf59ae4461eec74a180d77783d9064d2aa3a58.zip
hdf5-4dcf59ae4461eec74a180d77783d9064d2aa3a58.tar.gz
hdf5-4dcf59ae4461eec74a180d77783d9064d2aa3a58.tar.bz2
[svn-r376] ./acconfig.h
./configure.in ./config/BlankForm ./src/H5.c Configure tries to figure out how to print `long long' types and then defines PRINTF_LL_WIDTH to be `ll' or `q' or something. It does this by running little sprintf() programs with various formats until it gets one that works. If this causes problems when cross compiling (like with parallel machines) then you may add the following to the appropriate config file: hdf5_cv_printf_ll=${hdf5_cv_printf_ll='ll'} or hdf5_cv_printf_ll=${hdf5_cv_printf_ll='q'} or hdf5_cv_printf_ll=${hdf5_cv_printf_ll='l'} ./config/intel-osf1 ./config/irix5.3 Updated these config files to match the others. This allows the `--enable-production' configure flag to work properly.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b4f36af..676fcdc 100644
--- a/configure.in
+++ b/configure.in
@@ -204,6 +204,28 @@ AC_TRY_COMPILE(,[int f(void){return __FUNCTION__;}],
AC_MSG_RESULT(no))
dnl ----------------------------------------------------------------------
+dnl Try to figure out how to print `long long'. Some machines use `%lld'
+dnl and others use `%qd'. There may be more! The final `l' is a
+dnl default in case none of the others work.
+dnl
+AC_MSG_CHECKING(how to print long long);
+AC_CACHE_VAL(hdf5_cv_printf_ll,
+ for hdf5_cv_printf_ll in ll q l; do
+ AC_TRY_RUN([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+ main() {char *s=malloc(128);
+ long long x = (long long)1048576 * (long long)1048576;
+ sprintf(s,"%${hdf5_cv_printf_ll}d",x);
+ exit (strcmp(s,"1099511627776"));}],
+ break)
+ done)
+AC_MSG_RESULT($hdf5_cv_printf_ll)
+AC_DEFINE_UNQUOTED(PRINTF_LL_WIDTH,"$hdf5_cv_printf_ll")
+
+
+dnl ----------------------------------------------------------------------
dnl Turn on debugging by setting compiler flags
dnl
AC_MSG_CHECKING(for debug flags);