summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1998-02-13 18:11:35 (GMT)
committerRobb Matzke <matzke@llnl.gov>1998-02-13 18:11:35 (GMT)
commitb7f699bdef7e15755865cc61cd3d16a9558c1cc5 (patch)
treeb73aa06394c1ff527459978ce4d1907d762cfcd3 /configure.in
parentedbd6152fde9f376360ce07af51b50a3e026327f (diff)
downloadhdf5-b7f699bdef7e15755865cc61cd3d16a9558c1cc5.zip
hdf5-b7f699bdef7e15755865cc61cd3d16a9558c1cc5.tar.gz
hdf5-b7f699bdef7e15755865cc61cd3d16a9558c1cc5.tar.bz2
[svn-r269] Added more searching for config files. The order is now:
cpu-vendor-os vendor-os cpu-os cpu-vendor os vendor cpu
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ff1ed70..9cd621b 100644
--- a/configure.in
+++ b/configure.in
@@ -34,11 +34,26 @@ fi
dnl ----------------------------------------------------------------------
dnl Source any special files that we need. These files normally aren't
dnl present but can be used by the maintainers to fine tune things like
-dnl turning on debug or profiling flags for the compiler.
+dnl turning on debug or profiling flags for the compiler. The search order
+dnl is:
+dnl
+dnl CPU-VENDOR-OS
+dnl VENDOR-OS
+dnl CPU-OS
+dnl CPU-VENDOR
+dnl OS
+dnl VENDOR
+dnl CPU
dnl
AC_MSG_CHECKING(for site config file)
site_config="none"
-for f in $host $host_vendor-$host_os $host_os; do
+for f in $host \
+ $host_vendor-$host_os \
+ $host_cpu-$host_os \
+ $host_cpu-$host_vendor \
+ $host_os \
+ $host_vendor \
+ $host_cpu ; do
if test -f config/$f; then
site_config=config/$f
break