summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRobb Matzke <matzke@llnl.gov>1999-08-20 17:05:14 (GMT)
committerRobb Matzke <matzke@llnl.gov>1999-08-20 17:05:14 (GMT)
commitdaf589e9eab06ad6d36c9c9ac746805b2b3fa335 (patch)
tree9d659c959ed8d3c1623f8c2eab331874a11503c6 /configure.in
parentae45f73e6a7b4d275628abc2b85fca3f276ea007 (diff)
downloadhdf5-daf589e9eab06ad6d36c9c9ac746805b2b3fa335.zip
hdf5-daf589e9eab06ad6d36c9c9ac746805b2b3fa335.tar.gz
hdf5-daf589e9eab06ad6d36c9c9ac746805b2b3fa335.tar.bz2
[svn-r1582] ./configure.in [1.2, 1.3]
./configure [REGENERATED] The checking for C9x types includes <stdint.h> if it exists. This should fix a bug on Linux RedHat 6.0 (untested).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 906e9aa..7ead0d3 100644
--- a/configure.in
+++ b/configure.in
@@ -136,7 +136,7 @@ AC_MSG_CHECKING(for production mode)
AC_ARG_ENABLE(production,
[ --enable-production Determines how to run the compiler.])
-case "X-$enableval" in
+case "X-$enable_production" in
X-yes)
AC_MSG_RESULT("production")
CONFIG_MODE=production
@@ -175,7 +175,8 @@ AC_HEADER_STDC
AC_HEADER_TIME
dnl Unix
AC_CHECK_HEADERS(sys/resource.h sys/time.h unistd.h sys/ioctl.h sys/stat.h)
-AC_CHECK_HEADERS(stddef.h setjmp.h stdint.h)
+AC_CHECK_HEADERS(stddef.h setjmp.h)
+AC_CHECK_HEADERS(stdint.h, C9x=yes)
dnl Windows
AC_CHECK_HEADERS(io.h winsock.h sys/timeb.h)
@@ -210,6 +211,12 @@ dnl Posix.1g types (C9x)
cat >>confdefs.h <<\EOF
#include <sys/types.h>
EOF
+if test "Xyes" = "X$C9x"; then
+ cat >>confdefs.h <<\EOF
+#include <stdint.h>
+EOF
+fi
+
AC_CHECK_SIZEOF( int8_t, 1)
AC_CHECK_SIZEOF( uint8_t, 1)
AC_CHECK_SIZEOF( int_least8_t, 1)