summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-09-24 16:51:42 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-09-24 16:51:42 (GMT)
commit530a55bbcdae9c20888dbed619444823f07b92ae (patch)
tree7143a8dd4213a8d77560541eaf4e4916c6366ad6 /configure.in
parent7a8eb55bce8ee35df6d5f4481ecd94fa62618689 (diff)
downloadhdf5-530a55bbcdae9c20888dbed619444823f07b92ae.zip
hdf5-530a55bbcdae9c20888dbed619444823f07b92ae.tar.gz
hdf5-530a55bbcdae9c20888dbed619444823f07b92ae.tar.bz2
[svn-r4470]
Purpose: Bug Fix Description: Some platforms which have a "Bourne" shell (/bin/sh) have ones which don't support the "let" operator. Solution: Had to remove my clever hack and replace with boring, old "echo -n" statements instead. *sigh* Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in49
1 files changed, 22 insertions, 27 deletions
diff --git a/configure.in b/configure.in
index c86f354..bcaaee7 100644
--- a/configure.in
+++ b/configure.in
@@ -1742,14 +1742,9 @@ cat >> src/H5config.h <<EOF
#endif
EOF
-PRINT() {
- SPACES=" "
- msg="$SPACES $1: "
- msg_len="`echo \"$msg\" | wc -c | sed -e 's/ //g'`"
- let "begin_msg=$msg_len-34"
- echo "$msg" | cut -c$begin_msg- | tr -d '\012'
-}
-
+dnl ----------------------------------------------------------------------
+dnl Print out a summary of what we are going to build.
+dnl
IF_YES_NO() {
if test "$1" = "yes"; then
echo "Yes"
@@ -1769,7 +1764,7 @@ IF_ENABLED_DISABLED() {
echo ""
echo "Compiling Options:"
-PRINT "Compilation Mode"
+echo -n " Compilation Mode: "
case "X-$enable_production" in
X-yes) echo "Production" ;;
X-|X-no) echo "Development" ;;
@@ -1777,7 +1772,7 @@ case "X-$enable_production" in
*) echo "$enable_production" ;;
esac
-PRINT "Debug Mode"
+echo -n " Debug Mode: "
case "X-$DEBUG_PKG" in
X-|X-yes) echo "Default" ;;
X-all) echo "All" ;;
@@ -1785,16 +1780,16 @@ case "X-$DEBUG_PKG" in
*) echo "$DEBUG_PKG" ;;
esac
-PRINT "Shared Libraries"
+echo -n " Shared Libraries: "
IF_YES_NO "$enable_shared"
-PRINT "Static Libraries"
+echo -n " Static Libraries: "
IF_YES_NO "$enable_static"
-PRINT "Statically Linked Executables"
+echo -n " Statically Linked Executables: "
IF_YES_NO "$STATIC_EXEC"
-PRINT "Tracing"
+echo -n " Tracing: "
if test -z "$TRACE" -o "X$TRACE" = "Xyes"; then
echo "Yes"
else
@@ -1804,48 +1799,48 @@ fi
echo ""
echo "Features:"
-PRINT "C++"
+echo -n " C++: "
IF_YES_NO "$HDF_CXX"
-PRINT "Fortran"
+echo -n " Fortran: "
IF_YES_NO "$HDF_FORTRAN"
-PRINT "GASS"
+echo -n " GASS: "
IF_YES_NO "$GASS"
-PRINT "GridStorage"
+echo -n " GridStorage: "
IF_YES_NO "$GRIDSTORAGE"
-PRINT "HDF4"
+echo -n " HDF4: "
IF_YES_NO "$HAVE_HDF4"
-PRINT "HDF5 v1.4 Compatibility"
+echo -n " HDF5 v1.4 Compatibility: "
IF_YES_NO "$HDF5_V1_4_COMPAT"
-PRINT "hsize_t"
+echo -n " hsize_t: "
case "$HSIZET" in
no|small) echo "Small" ;;
*) echo "Large" ;;
esac
-PRINT "Linux Large File Support (LFS)"
+echo -n " Linux Large File Support (LFS): "
IF_ENABLED_DISABLED "$LINUX_LFS"
-PRINT "Parallel HDF5"
+echo -n " Parallel HDF5: "
if test "$PARALLEL" != "no"; then
echo "Yes"
else
echo "No"
fi
-PRINT "SRB"
+echo -n " SRB: "
IF_YES_NO "$SRB"
-PRINT "Stream VFD"
+echo -n " Stream VFD: "
IF_ENABLED_DISABLED "$STREAM_VFD"
-PRINT "Threadsafety"
+echo -n " Threadsafety: "
IF_ENABLED_DISABLED "$THREADSAFE"
-PRINT "Zlib-compression"
+echo -n " Zlib-compression: "
IF_YES_NO "$HAVE_ZLIB"