summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 19:24:56 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 19:24:56 (GMT)
commit960e7dc164aebd68340947ac8287f0ee4030e4ef (patch)
treef169e361b6609133ba09bff693a0b680db1dcec7 /configure.in
parent7db648599a3e449a503c2b4bd413d5b7785a3c5d (diff)
downloadhdf5-960e7dc164aebd68340947ac8287f0ee4030e4ef.zip
hdf5-960e7dc164aebd68340947ac8287f0ee4030e4ef.tar.gz
hdf5-960e7dc164aebd68340947ac8287f0ee4030e4ef.tar.bz2
[svn-r5234] Purpose:
Update Description: Updated the way some of the macros were being used in the configure file. Some of the behavior is deprecated. Mostly has to do with the AC_OUTPUT and AC_INIT macros... Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in105
1 files changed, 59 insertions, 46 deletions
diff --git a/configure.in b/configure.in
index 60f6d91..3ac9eae 100644
--- a/configure.in
+++ b/configure.in
@@ -8,8 +8,20 @@ dnl ----------------------------------------------------------------------
dnl Initialize configure.
dnl
AC_REVISION($Id$)
-AC_INIT(src/H5.c)
-AC_CONFIG_HEADER(src/H5config.h)
+
+dnl AC_INIT takes the name of the package, the version number, and an
+dnl email address to report bugs. AC_CONFIG_SRCDIR takes a unique file
+dnl as its argument.
+dnl
+dnl NOTE: Don't forget to change the version number here when we do a
+dnl release!!!
+dnl
+AC_INIT([HDF5], [1.4.4], [hdfhelp@ncsa.uiuc.edu])
+AC_CONFIG_SRCDIR([src/H5.c])
+AC_CONFIG_HEADER([src/H5config.h])
+
+AC_CONFIG_AUX_DIR([bin])
+
AC_OUTPUT_COMMANDS([
echo "creating src/H5pubconf.h"
sed 's/#define /#define H5_/' <src/H5config.h |\
@@ -23,7 +35,7 @@ AC_OUTPUT_COMMANDS([
/bin/mv -f pubconf src/H5pubconf.h
fi
])
-AC_CONFIG_AUX_DIR(bin)
+
AC_CANONICAL_HOST
AC_SUBST(CPPFLAGS)
@@ -114,16 +126,16 @@ esac
host_config="none"
for f in $host_cpu-$host_vendor-$host_os \
- $host_cpu-$host_vendor-$host_os_novers \
- $host_vendor-$host_os \
+ $host_cpu-$host_vendor-$host_os_novers \
+ $host_vendor-$host_os \
$host_vendor-$host_os_novers \
- $host_cpu-$host_os \
+ $host_cpu-$host_os \
$host_cpu-$host_os_novers \
$host_cpu-$host_vendor \
- $host_os \
- $host_os_novers \
- $host_vendor \
- $host_cpu ; do
+ $host_os \
+ $host_os_novers \
+ $host_vendor \
+ $host_cpu ; do
AC_MSG_CHECKING(for config $f)
if test -f "$srcdir/config/$f"; then
host_config=$srcdir/config/$f
@@ -257,7 +269,7 @@ esac
AC_MSG_CHECKING(make)
AC_SUBST_FILE(DEPEND)
if test "`${MAKE-make} --version -f /dev/null 2>/dev/null |\
- sed -n 1p|cut -c1-8`" = "GNU Make"; then
+ sed -n 1p|cut -c1-8`" = "GNU Make"; then
AC_MSG_RESULT(GNU make)
GMAKE=yes
if test "X$GCC" = "Xyes"; then
@@ -1602,41 +1614,42 @@ if test -n "$TESTPARALLEL"; then
PARALLEL_MAKE="$TESTPARALLEL/Makefile"
fi
-AC_OUTPUT(src/libhdf5.settings
- config/depend1
- config/depend2
- config/depend3
- config/depend4
- config/dependN
- config/commence
- config/conclude
- Makefile
- src/Makefile
- pablo/Makefile
- test/Makefile
- $PARALLEL_MAKE
- perform/Makefile
- tools/Makefile
- tools/h5dump/Makefile
- tools/h5ls/Makefile
- tools/lib/Makefile
- tools/misc/Makefile
- tools/misc/h5cc
- tools/gifconv/Makefile
- examples/Makefile
- doc/Makefile
- doc/html/Makefile
- doc/html/ADGuide/Makefile
- doc/html/Graphics/Makefile
- doc/html/Intro/Makefile
- doc/html/PSandPDF/Makefile
- doc/html/TechNotes/Makefile
- doc/html/Tutor/Makefile
- doc/html/Tutor/Graphics/Makefile
- doc/html/Tutor/examples/Makefile
- doc/html/Tutor/examples/java/Makefile
- doc/html/cpplus/Makefile
- doc/html/fortran/Makefile)
+AC_CONFIG_FILES([src/libhdf5.settings
+ config/depend1
+ config/depend2
+ config/depend3
+ config/depend4
+ config/dependN
+ config/commence
+ config/conclude
+ Makefile
+ src/Makefile
+ pablo/Makefile
+ test/Makefile
+ $PARALLEL_MAKE
+ perform/Makefile
+ tools/Makefile
+ tools/h5dump/Makefile
+ tools/h5ls/Makefile
+ tools/lib/Makefile
+ tools/misc/Makefile
+ tools/misc/h5cc
+ tools/gifconv/Makefile
+ examples/Makefile
+ doc/Makefile
+ doc/html/Makefile
+ doc/html/ADGuide/Makefile
+ doc/html/Graphics/Makefile
+ doc/html/Intro/Makefile
+ doc/html/PSandPDF/Makefile
+ doc/html/TechNotes/Makefile
+ doc/html/Tutor/Makefile
+ doc/html/Tutor/Graphics/Makefile
+ doc/html/Tutor/examples/Makefile
+ doc/html/Tutor/examples/java/Makefile
+ doc/html/cpplus/Makefile
+ doc/html/fortran/Makefile])
+AC_OUTPUT
no_create=$saved_no_create
# Then the stamp2 file for H5config.h