summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-01-12 18:44:52 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-01-12 18:44:52 (GMT)
commita1551e334d3cae6a4c0aa1e075a9f397648dddb3 (patch)
treeede069355afafc18973b7cb12a51cd1971b2de74 /configure.in
parent3015b2ccc8c3d8a2c6af6677afb8c5094565ecc1 (diff)
downloadhdf5-a1551e334d3cae6a4c0aa1e075a9f397648dddb3.zip
hdf5-a1551e334d3cae6a4c0aa1e075a9f397648dddb3.tar.gz
hdf5-a1551e334d3cae6a4c0aa1e075a9f397648dddb3.tar.bz2
[svn-r3279] Purpose:
Warning Reduction Description: Removed the -Wpointer-arith flag which complains about addintion with void * pointers. This is a known gcc 2.95.2 annoyance. There's still some issues with many str* warnings...not 7000, though. Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b375918..1732c04 100644
--- a/configure.in
+++ b/configure.in
@@ -336,7 +336,7 @@ dnl ----------------------------------------------------------------------
dnl Turn on warning flags for gcc.
dnl
if test "X$GCC" = "Xyes"; then
- CFLAGS="$CFLAGS -ansi -pedantic -Wchar-subscripts -Wconversion -Wredundant-decls -Wall -W -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline"
+ CFLAGS="$CFLAGS -ansi -pedantic -Wchar-subscripts -Wconversion -Wredundant-decls -Wall -W -Wshadow -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline"
fi
dnl ----------------------------------------------------------------------