summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2001-06-25 22:48:38 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2001-06-25 22:48:38 (GMT)
commit1a4c6d996697bc5080426314e9f0f1167d2115cc (patch)
tree535aae22e56fd9f5ac02f3f90d8ca9e35123e386 /configure.in
parent997ae15cc8db44ae680f317bffcc2dcce42369e3 (diff)
downloadhdf5-1a4c6d996697bc5080426314e9f0f1167d2115cc.zip
hdf5-1a4c6d996697bc5080426314e9f0f1167d2115cc.tar.gz
hdf5-1a4c6d996697bc5080426314e9f0f1167d2115cc.tar.bz2
[svn-r4070] Description:
Put the enable-hdf5v1_2 back in. Platforms tested: modi4 (parallel), eirene (with and without enable-hdf5v1_2 on).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 923d937..9b74ee1 100644
--- a/configure.in
+++ b/configure.in
@@ -920,6 +920,22 @@ if test "X$THREADSAFE" = "Xyes"; then
fi
dnl ----------------------------------------------------------------------
+dnl Check if they would like the HDF5 v1.2 compatibility functions
+dnl compiled in
+dnl
+AC_MSG_CHECKING(whether HDF5 v1.2 compatibility functions enabled)
+AC_ARG_ENABLE(hdf5v1_2,
+ [ --enable-hdf5v1_2 Compile the HDF5 v1.2 compatibility interface [default=no]],
+ HDF5_V1_2_COMPAT=$enableval)
+
+if test "X$HDF5_V1_2_COMPAT" = "Xyes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WANT_H5_V1_2_COMPAT)
+else
+ AC_MSG_RESULT(no)
+fi
+
+dnl ----------------------------------------------------------------------
dnl Should the Stream Virtual File Driver be compiled in ?
dnl
AC_MSG_CHECKING(for Stream Virtual File Driver support)