summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-03-22 18:15:04 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-03-22 18:15:04 (GMT)
commitc041a0dc929fdfdd80a623279b3678a882e229cc (patch)
treec19e93559e4943f724b9f8c8262efc1e3db5806a /configure.in
parent011b427e13edd9eecf8a161a2c0f4a6c838bf8da (diff)
downloadhdf5-c041a0dc929fdfdd80a623279b3678a882e229cc.zip
hdf5-c041a0dc929fdfdd80a623279b3678a882e229cc.tar.gz
hdf5-c041a0dc929fdfdd80a623279b3678a882e229cc.tar.bz2
[svn-r3691] Purpose:
Bug FIx Description: Makefiles were being generated for the HDF4 and parallel stuff even if they weren't being used. Solution: Conditionally create those files now. I check if the Parallel and HDF4 stuff is specified and then create them. Platforms tested: Modi4 and Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 26 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 70a3c9b..d656d7d 100644
--- a/configure.in
+++ b/configure.in
@@ -235,6 +235,14 @@ AC_PROG_INSTALL
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL
+dnl Fix up the INSTALL macro if it's a relative path. We want the
+dnl full-path to the binary instead.
+case "$INSTALL" in
+ *install-sh*)
+ INSTALL='\${top_srcdir}'/bin/install-sh
+ ;;
+esac
+
AC_MSG_CHECKING(make)
AC_SUBST_FILE(DEPEND)
if test "`${MAKE-make} --version -f /dev/null 2>/dev/null |\
@@ -1546,6 +1554,22 @@ dnl things need to be done.
mkdir ./config >/dev/null 2>&1
touch ./config/stamp1
+PARALLEL_MAKE=
+
+if test -n "$TESTPARALLEL"; then
+ PARALLEL_MAKE="$TESTPARALLEL/Makefile"
+fi
+
+EXTRA_H4_MAKEFILES=
+
+if test -n "$H4TOH5"; then
+ EXTRA_H4_MAKEFILES="$EXTRA_H4_MAKEFILES tools/h4toh5/Makefile"
+fi
+
+if test -n "$H5TOH4"; then
+ EXTRA_H4_MAKEFILES="$EXTRA_H4_MAKEFILES tools/h5toh4/Makefile"
+fi
+
# Then the config.status file (but not makefiles)
saved_no_create=$no_create
no_create=yes
@@ -1561,14 +1585,13 @@ AC_OUTPUT(src/libhdf5.settings
src/Makefile
pablo/Makefile
test/Makefile
- testpar/Makefile
+ $PARALLEL_MAKE
tools/Makefile
- tools/h4toh5/Makefile
tools/h5dump/Makefile
tools/h5ls/Makefile
- tools/h5toh4/Makefile
tools/lib/Makefile
tools/misc/Makefile
+ $EXTRA_H4_MAKEFILES
examples/Makefile
doc/Makefile
doc/html/Makefile
@@ -1580,7 +1603,6 @@ AC_OUTPUT(src/libhdf5.settings
doc/html/Tutor/Makefile
doc/html/Tutor/Graphics/Makefile
doc/html/Tutor/examples/Makefile
- doc/html/Tutor/examples/java/Makefile
doc/html/cpplus/Makefile
doc/html/fortran/Makefile)
no_create=$saved_no_create