summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-07-17 18:03:38 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-07-17 18:03:38 (GMT)
commit33f0045d9a935fe82f07b039e0654e44b3277765 (patch)
tree6032e5fe83ad8cd77d681e193a58f34b12280d7e /configure.in
parent4be014fc14ff9d311fdfb0417d8f3e738f03a88a (diff)
downloadhdf5-33f0045d9a935fe82f07b039e0654e44b3277765.zip
hdf5-33f0045d9a935fe82f07b039e0654e44b3277765.tar.gz
hdf5-33f0045d9a935fe82f07b039e0654e44b3277765.tar.bz2
[svn-r5810] Purpose:
Fix Description: Better check for versions of Linux. We didn't support kernels with major version numbers >2 and minor version numbers <4... Solution: Fixed to check just that. Platforms tested: Linux 2.2 && 2.4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 53820e1..9a9f3fc 100644
--- a/configure.in
+++ b/configure.in
@@ -512,7 +512,7 @@ case "$host_cpu-$host_vendor-$host_os" in
MAJOR_VER="`uname -r | cut -d '.' -f1`"
MINOR_VER="`uname -r | cut -d '.' -f2`"
- if test $MAJOR_VER -ge 2 -a $MINOR_VER -ge 4; then
+ if test ${MAJOR_VER} -gt 2 -o ${MAJOR_VER} -eq 2 -a ${MINOR_VER} -ge 4; then
LINUX_LFS="yes"
fi
;;