summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2003-09-16 17:35:31 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2003-09-16 17:35:31 (GMT)
commit9b152820077fc8ddff99704b8cc3e1a63ce4093c (patch)
treeeb470ebab67e13a4b690096e9fa2fae09a366dca /configure.in
parent58b49c8302b3adc3890f7f0c7b4da291fd34562a (diff)
downloadhdf5-9b152820077fc8ddff99704b8cc3e1a63ce4093c.zip
hdf5-9b152820077fc8ddff99704b8cc3e1a63ce4093c.tar.gz
hdf5-9b152820077fc8ddff99704b8cc3e1a63ce4093c.tar.bz2
[svn-r7481] Purpose:
Bug fix Description: The MPI_File_set_size() routine on ASCI Red is not able to extend files so that they are larger than 2GB. Solution: Add an extra macro which controls whether MPI_File_set_size() can handle >2GB offsets or if our "older" way of reading a byte, then writing a byte at the appropriate offset should be used. Platforms tested: FreeBSD 4.9 (sleipnir) h5committest
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 17c897b..9f4186d 100644
--- a/configure.in
+++ b/configure.in
@@ -1548,7 +1548,7 @@ int main(void)
if test ${hdf5_cv_malloc_works} = "yes"; then
AC_DEFINE(MALLOC_WORKS, 1,
- [Define if your system has a working \`malloc' function.])
+ [Define if your system's \`malloc' function returns a valid pointer for 0-byte allocations.])
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
@@ -2058,6 +2058,24 @@ dnl AC_MSG_RESULT(yes)
dnl else
dnl AC_MSG_RESULT(no)
dnl fi
+
+ dnl ----------------------------------------------------------------------
+ dnl Set the flag to indicate that the MPI_File_set_size() function
+ dnl works with files over 2GB, unless it's already set in the cache.
+ dnl (This flag should be set for all machines, except for ASCI Red, where
+ dnl the cache value is set in it's config file)
+ dnl
+ AC_MSG_CHECKING([if MPI_File_set_size works for files over 2GB])
+ AC_CACHE_VAL([hdf5_cv_mpi_file_set_size_big], [hdf5_cv_mpi_file_set_size_big=yes])
+
+ if test ${hdf5_cv_mpi_file_set_size_big} = "yes"; then
+ AC_DEFINE([MPI_FILE_SET_SIZE_BIG], [1],
+ [Define if your system's \`MPI_File_set_size' function works for files over 2GB.])
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+
fi
dnl ----------------------------------------------------------------------