summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-09-29 20:00:06 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-09-29 20:00:06 (GMT)
commit246fb66cd819d7639fe9d94bfb6a6a542e01d099 (patch)
tree19b1fcdc871af5eede2b209eae547ab6539626a6 /configure.in
parent235ad61cdef961d30b199b0884c28dc2df3bbfaf (diff)
downloadhdf5-246fb66cd819d7639fe9d94bfb6a6a542e01d099.zip
hdf5-246fb66cd819d7639fe9d94bfb6a6a542e01d099.tar.gz
hdf5-246fb66cd819d7639fe9d94bfb6a6a542e01d099.tar.bz2
[svn-r11482] Purpose:
feature. Description: added the recognition of -lmpich as a form of MPI library. Platforms tested: v1.7 tested out fine. Folded this to v1.6. Document: RELEASE.txt updated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 48ff7f4..093bc6e 100644
--- a/configure.in
+++ b/configure.in
@@ -1935,8 +1935,11 @@ case "X-$enable_parallel" in
AC_MSG_RESULT([provided by compiler])
PARALLEL=yes
- dnl Try link a simple MPI program. If fail, try again with -lmpi.
- AC_TRY_LINK(, MPI_Init(),, AC_CHECK_LIB(mpi, MPI_Init,, PARALLEL=no))
+ dnl Try link a simple MPI program. If fail, try again with -lmpi and
+ dnl -lmpich.
+ AC_TRY_LINK(, MPI_Init(),, \
+ AC_CHECK_LIB(mpi, MPI_Init,, \
+ AC_CHECK_LIB(mpich, MPI_Init,, PARALLEL=no)))
dnl Then try link a simple MPI-IO program. If fail, try again with
dnl -lmpio.