summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-05-15 21:25:52 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-05-15 21:25:52 (GMT)
commit70cdaa12b2bceadd6a6f6d7b66eaad626e8523d6 (patch)
treef97f0ecc4e035a9e786c5307d7359dbc9aeb83df /configure.in
parent484b4c47c3e0b5905c61eb536626ab5b098885c7 (diff)
downloadhdf5-70cdaa12b2bceadd6a6f6d7b66eaad626e8523d6.zip
hdf5-70cdaa12b2bceadd6a6f6d7b66eaad626e8523d6.tar.gz
hdf5-70cdaa12b2bceadd6a6f6d7b66eaad626e8523d6.tar.bz2
[svn-r15013] Purpose: Configure Macro Modification
Description: The macro H5_HAVE_WINDOW_PATH is now defined to 1 only when MinGW is in use. This is needed to fix the "links" test, and the external link feature in the library. Tested: kagiso
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 10 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 8fff9a0..6a40a77 100644
--- a/configure.in
+++ b/configure.in
@@ -2850,16 +2850,17 @@ dnl (This flag should be _unset_ for all machines, except for Windows, where
dnl it's set in the custom Windows H5pubconf.h file)
dnl
AC_MSG_CHECKING([if the machine has window style path name])
-AC_CACHE_VAL([hdf5_have_window_path], [hdf5_have_window_path=no])
-
-if test ${hdf5_have_window_path} = "yes"; then
- AC_DEFINE([HAVE_WINDOW_PATH], [1],
- [Define if your system has window style path name.])
- AC_MSG_RESULT([true])
-else
- AC_MSG_RESULT([false])
-fi
+case "`uname`" in
+ MINGW*)
+ AC_DEFINE([HAVE_WINDOW_PATH], [1],
+ [Define if your system has window style path name.])
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ AC_MSG_RESULT([no])
+ ;;
+esac
dnl -----------------------------------------------------------------------
dnl Set flag to indicate that the machine can handle conversion from