summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-04-24 20:41:51 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-04-24 20:41:51 (GMT)
commit82198aa9c51c198d95efebfd1c0dd8a58d3e4da8 (patch)
tree2e0b4defb5b9247b14224e47122d2577526a17cd /configure.in
parente66cb6fec6dd5edcb6060ac8e2678a8e406db8d9 (diff)
downloadhdf5-82198aa9c51c198d95efebfd1c0dd8a58d3e4da8.zip
hdf5-82198aa9c51c198d95efebfd1c0dd8a58d3e4da8.tar.gz
hdf5-82198aa9c51c198d95efebfd1c0dd8a58d3e4da8.tar.bz2
[svn-r14862] Purpose: Disallow use of c++ or fortran with threadsafe.
Description: Threadsafety is incompatible with c++ and with fortran, so if the user specifies either at configure along with threadsafe, throw an error. Tested: kagiso (configure change only, doesn't affect build or testing).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5d3f3a6..24087b6 100644
--- a/configure.in
+++ b/configure.in
@@ -1681,6 +1681,17 @@ AC_ARG_ENABLE([threadsafe],
[Enable thread safe capability])],
THREADSAFE=$enableval)
+dnl The --enable-threadsafe flag is not compatible with --enable-cxx.
+dnl If the user tried to specify both flags, throw an error.
+if test "X${HDF_CXX}" = "Xyes" -a "X${enable_threadsafe}" = "Xyes"; then
+ AC_MSG_ERROR([--enable-cxx and --enable-threadsafe flags are incompatible])
+fi
+
+dnl --enable-threadsafe is also incompatible with --enable-fortran.
+if test "X${HDF_FORTRAN}" = "Xyes" -a "X${enable_threadsafe}" = "Xyes"; then
+ AC_MSG_ERROR([--enable-fortran and --enable-threadsafe flags are incompatible])
+fi
+
case "X-$THREADSAFE" in
X-|X-no)
AC_MSG_RESULT([no])