summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2008-04-02 19:33:08 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2008-04-02 19:33:08 (GMT)
commitcff7516ca7fe980f53037886b8a1faa181d6daec (patch)
tree1176ec7e168a3dd28b0616dec64b719d63ce22d6 /configure.in
parentd8dfc1fb3f07df5e58e9da6f5e54304e6e2009a9 (diff)
downloadhdf5-cff7516ca7fe980f53037886b8a1faa181d6daec.zip
hdf5-cff7516ca7fe980f53037886b8a1faa181d6daec.tar.gz
hdf5-cff7516ca7fe980f53037886b8a1faa181d6daec.tar.bz2
[svn-r14791] Add handling for external link:
1. src/H5F.c, src/H5system.c: formulate path for mainfile 2. src/H5Lexternal.c: add search for target file 3. configure.in: add H5_HAVE_WINDOW_PATH 4. test/links.c: add tests for external link
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f6bb937..0bbad7e 100644
--- a/configure.in
+++ b/configure.in
@@ -2814,6 +2814,24 @@ else
AC_MSG_RESULT([false])
fi
+dnl ----------------------------------------------------------------------
+dnl Set the flag to indicate that the machine has window style pathname,
+dnl that is, "drive-letter:\" (e.g. "C:") or "drive-letter:/" (e.g. "C:/").
+dnl (This flag should be _unset_ for all machines, except for Windows, where
+dnl it's set in the custom Windows H5pubconf.h file)
+dnl
+AC_MSG_CHECKING([if the machine has window style path name])
+AC_CACHE_VAL([hdf5_have_window_path], [hdf5_have_window_path=no])
+
+if test ${hdf5_have_window_path} = "yes"; then
+ AC_DEFINE([HAVE_WINDOW_PATH], [1],
+ [Define if your system has window style path name.])
+ AC_MSG_RESULT([true])
+else
+ AC_MSG_RESULT([false])
+fi
+
+
dnl -----------------------------------------------------------------------
dnl Set flag to indicate that the machine can handle conversion from
dnl long double to integers accurately. This flag should be set "yes" for