summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-03-09 17:53:01 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-03-09 17:53:01 (GMT)
commit1b0e131cc415a72269cdcb8f93669c7e94412ced (patch)
tree10215c6806a9f1a764a40b6e593f8c5e7cf8d1e1 /configure.in
parent363046bef9acc4126e931c660e1e2bbf1fa7c9a7 (diff)
downloadhdf5-1b0e131cc415a72269cdcb8f93669c7e94412ced.zip
hdf5-1b0e131cc415a72269cdcb8f93669c7e94412ced.tar.gz
hdf5-1b0e131cc415a72269cdcb8f93669c7e94412ced.tar.bz2
[svn-r16555] Purpose:
Bug Fix Description: Removing the code from configure which strips the '-g' flag from CFLAGS when in production mode. The current default CFLAGS in production mode does not include '-g', as intended, but we should allow users to override this and enable '-g' by setting the CFLAGS environment variable if desired. Note that this applies to FCFLAGS and CXXFLAGS as well. Tested: kagiso, linew, liberty
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.in b/configure.in
index 75d74f0..6d72e85 100644
--- a/configure.in
+++ b/configure.in
@@ -1142,39 +1142,6 @@ case "X-$enable_production" in
X-|X-yes)
enable_production="yes"
AC_MSG_RESULT([production])
-
- dnl Remove the "-g" flag from CFLAGS if it's in there.
- dnl
- CFLAGS_temp=""
- if test -n "$CFLAGS"; then
- for d in $CFLAGS ; do
- if test "X$d" != "X-g"; then
- CFLAGS_temp="$CFLAGS_temp $d"
- fi
- done
- CFLAGS=$CFLAGS_temp
- fi
-
- CXXFLAGS_temp=""
- if test -n "$CXXFLAGS"; then
- for d in $CXXFLAGS ; do
- if test "X$d" != "X-g"; then
- CXXFLAGS_temp="$CXXFLAGS_temp $d"
- fi
- done
- CXXFLAGS=$CXXFLAGS_temp
- fi
-
- FCFLAGS_temp=""
- if test -n "$FCFLAGS"; then
- for d in $FCFLAGS ; do
- if test "X$d" != "X-g"; then
- FCFLAGS_temp="$FCFLAGS_temp $d"
- fi
- done
- FCFLAGS=$FCFLAGS_temp
- fi
-
CONFIG_MODE=production
H5_CFLAGS="$H5_CFLAGS $PROD_CFLAGS"
H5_CPPFLAGS="$H5_CPPFLAGS $PROD_CPPFLAGS"