summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2012-03-30 21:00:55 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2012-03-30 21:00:55 (GMT)
commit5799eccab8aec8921773a2a1706b13c3cd79a925 (patch)
treedd6f882f009d8457528f8d1784251773503627b3 /configure.in
parent56d950d3264aae3d935854470a9178a333614bff (diff)
downloadhdf5-5799eccab8aec8921773a2a1706b13c3cd79a925.zip
hdf5-5799eccab8aec8921773a2a1706b13c3cd79a925.tar.gz
hdf5-5799eccab8aec8921773a2a1706b13c3cd79a925.tar.bz2
[svn-r22210] Purpose:
Merge fix for HDFFV-944 (r22149) from trunk to hdf5_1_8. (Also reran bin/reconfigure which updated trace information for the two new MPI functions for getting/setting atomicity in src/H5Fmpi.c) Tested: h5committest
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 17 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index ef9f0c5..657fea4 100644
--- a/configure.in
+++ b/configure.in
@@ -1038,24 +1038,6 @@ dnl or disabled, it should happen before these macros.
LT_PREREQ([2.2])
LT_INIT([dlopen])
-dnl Post processing to patch up some deficiencies in libtool (as of
-dnl Libtool 1.5.14)
-case $host_os in
- linux* | freebsd* )
- # If gcc is not used, need to set $wl to use "-Wl,"
- if $CC -v 2>&1 | grep '^gcc' > /dev/null ; then
- : using gcc
- else
- echo 'fixing $wl in' $ofile
-ed - $ofile <<EOF 2> /dev/null
-/^wl=""/s//wl="-Wl,"/
-w
-q
-EOF
- fi
- ;;
-esac
-
dnl ----------------------------------------------------------------------
dnl Check if we should install only statically linked executables.
dnl This check needs to occur after libtool is initialized because
@@ -4516,6 +4498,23 @@ touch ./config/stamp2
# Finally the makefiles
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
+dnl Post processing to patch up some deficiencies in libtool
+case $host_os in
+ linux* | freebsd* )
+ # If gcc is not used, need to set $wl to use "-Wl,"
+ if $CC -v 2>&1 | grep '^gcc' > /dev/null ; then
+ : using gcc
+ else
+ echo 'fixing $wl in' $ofile
+ed - $ofile <<EOF 2> /dev/null
+g/^wl=""/s//wl="-Wl,"/
+w
+q
+EOF
+ fi
+ ;;
+esac
+
dnl Are we compiling static libraries, shared libraries, or both? This
dnl is only used for the libhdf5.settings file. We can't just look at
dnl $enable_static and $enable_shared because if they're yes the ltconfig