summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-08-06 19:37:50 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-08-06 19:37:50 (GMT)
commit7b375507aeb4c0d72d7d192c53e162a1312b0caa (patch)
treedf9ab7726efa7b00d82bdda56bcbd6dfbb4f0476 /configure.in
parentab1051e0b00552006f4cc37d97cbf505fdc6eb3c (diff)
downloadhdf5-7b375507aeb4c0d72d7d192c53e162a1312b0caa.zip
hdf5-7b375507aeb4c0d72d7d192c53e162a1312b0caa.tar.gz
hdf5-7b375507aeb4c0d72d7d192c53e162a1312b0caa.tar.bz2
[svn-r19186] Bug fix: ID 1917
In some machine (Linux), when --disable-largefile is used, it claims it has fseeko64 but off64_t is NOT supported. Moved the test of fseeko64 and ftello64 to where fseek64 is so that they are tested only if off64_t is supported. Tested: h5committested.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1be03cb..a964fca 100644
--- a/configure.in
+++ b/configure.in
@@ -1368,9 +1368,9 @@ CPPFLAGS="$AM_CPPFLAGS $CPPFLAGS"
AC_TRY_COMPILE([#include <sys/types.h>],
[off64_t n = 0;],
- [AC_CHECK_FUNCS([lseek64 fseek64 ftruncate64])],
- [AC_MSG_RESULT([skipping test for lseek64(), fseek64(), ftruncate64()])])
-AC_CHECK_FUNCS(fseeko fseeko64 ftello ftello64)
+ [AC_CHECK_FUNCS([lseek64 fseek64 fseeko64 ftello64 ftruncate64])],
+ [AC_MSG_RESULT([skipping test for lseek64(), fseek64(), fseeko64 , ftello64, ftruncate64() because off64_t is not defined])])
+AC_CHECK_FUNCS(fseeko ftello)
AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/stat.h>],