summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-10-15 21:53:36 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-10-15 21:53:36 (GMT)
commit97cced22b65a7cea43ce772b252d5a7ed670edc7 (patch)
treea1a9dac4ad2978b1894adfe28ff6de8ab6aacf07 /configure.in
parentb353fb8b5a51f8ba853df9512d7ab57e66f86395 (diff)
downloadhdf5-97cced22b65a7cea43ce772b252d5a7ed670edc7.zip
hdf5-97cced22b65a7cea43ce772b252d5a7ed670edc7.tar.gz
hdf5-97cced22b65a7cea43ce772b252d5a7ed670edc7.tar.bz2
[svn-r15881] Purpose: Bug Fixes, Libtool Upgrade
Description: 1) configure now sets LD_LIBRARY_PATH before checking for presence of SZIP encoder, so user does not need to set this. The path is then saved and sent to Makefiles, and used when "make check-install" is invoked, so user doesn't need to set this manually. 2) Upgraded libtool to version 2.2.6a 3) Rearranged tools build order as h5dump depends on existence of h5diff and h5import. Since h5dump is a sister directory as opposed to a parent of either, it doesn't know about the build rules of these tools, so setting any sort of explicit dependency confuses automake as it won't know how to build the tools. Instead, setting CONFIG = ordered forces an in-order traversal of each tools subdirectory. (without it will also traverse in order by default, but this should prevent gmake's -j option from jumping ahead as well). 'make check install' should now be able to be invoked after 'configure' without causing a dependency failure. 4) Removed H5_HAVE_LARGE_HSIZET macro from vms/src/h5pubconf.h, as this macro has now been out of the code for some time. (vms pubconf needs to be updated manually, which is why it was still hanging around). Tested: kagiso, smirom, liberty Note: h5diff looks to be causing failures in h5copy and h5dump tools tests, though these were present before any of my changes. My changes only affect build order and configuration setup, and shouldn't prevent fixes for these failures coming in after this checkin. Other than these, tests pass fine.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 13 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index 51b79fe..e7c0711 100644
--- a/configure.in
+++ b/configure.in
@@ -1673,17 +1673,12 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
dnl SZLIB library is available. Check if it can encode
AC_MSG_CHECKING([for szlib encoder])
- AC_CACHE_VAL([hdf5_cv_szlib_functional],
- [AC_TRY_RUN([
- #include <szlib.h>
-
- int main(void)
- {
- SZ_encoder_enabled();
- exit(0);
- }
- ], [hdf5_cv_szlib_functional=yes], [hdf5_cv_szlib_functional=no],)])
-
+ dnl Set LD_LIBRARY_PATH so encoder test can find the library and run.
+ dnl Also add LL_PATH substitution to Makefiles so they can use the
+ dnl path as well, for testing examples.
+ export LD_LIBRARY_PATH="$szlib_lib"
+ AC_SUBST([LL_PATH]) LL_PATH="$szlib_lib"
+
AC_CACHE_VAL([hdf5_cv_szlib_can_encode],
[AC_TRY_RUN([
#include <szlib.h>
@@ -1698,24 +1693,17 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
}
], [hdf5_cv_szlib_can_encode=yes], [hdf5_cv_szlib_can_encode=no],)])
- if test ${hdf5_cv_szlib_functional} = "no"; then
- hdf5_cv_szlib_can_encode=broken
- else
- AC_DEFINE(HAVE_FILTER_SZIP, 1,
- [Define if support for szip filter is enabled])
- USE_FILTER_SZIP="yes"
- fi
-
+ AC_DEFINE(HAVE_FILTER_SZIP, 1,
+ [Define if support for szip filter is enabled])
+ USE_FILTER_SZIP="yes"
+
if test ${hdf5_cv_szlib_can_encode} = "yes"; then
AC_MSG_RESULT([yes])
fi
if test ${hdf5_cv_szlib_can_encode} = "no"; then
AC_MSG_RESULT([no])
fi
- if test ${hdf5_cv_szlib_can_encode} = "broken"; then
- AC_MSG_RESULT([shared szlib doesn't work. disabling szip.])
- fi
-
+
dnl Add "szip" to external filter list
if test ${hdf5_cv_szlib_can_encode} = "yes"; then
if test "X$EXTERNAL_FILTERS" != "X"; then
@@ -1732,6 +1720,8 @@ if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
fi
+AM_CONDITIONAL([BUILD_SZIP_CONDITIONAL], [test "X$USE_FILTER_SZIP" = "Xyes"])
+
dnl Checkpoint the cache
AC_CACHE_SAVE