summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2010-05-05 15:47:44 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2010-05-05 15:47:44 (GMT)
commitb93621ecf54c7df71408c46107adbe0e7a1c8b28 (patch)
tree9772e986cb77e480c2d56eb51147ac89247e4c94 /configure.in
parent3f3a900177d9464376ea7baf5f989cbfa0e86b0a (diff)
downloadhdf5-b93621ecf54c7df71408c46107adbe0e7a1c8b28.zip
hdf5-b93621ecf54c7df71408c46107adbe0e7a1c8b28.tar.gz
hdf5-b93621ecf54c7df71408c46107adbe0e7a1c8b28.tar.bz2
[svn-r18706] I changed the macro H5_CYGWIN (checked in with round 18696) to H5_CYGWIN_ULLONG_TO_LDOUBLE_ROUND_PROBLEM to make it more descriptive.
I tested on jam and Cygwin.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index eb0b8e3..bc9ff78 100644
--- a/configure.in
+++ b/configure.in
@@ -961,9 +961,15 @@ fi
dnl ----------------------------------------------------------------------
dnl Shared libraries are not currently supported under Cygwin.
+dnl
+dnl The GCC compiler on Cygwin running on Windows XP has rounding problem
+dnl in the data conversion dt_arith.c from unsigned long long to long
+dnl double (see bug #1813). I define a macro here to skip the test for
+dnl Cygwin. I'll come back and figure out the problem once I'm available.
+dnl 2010/5/5 - SLU
case "`uname`" in
CYGWIN*)
- AC_DEFINE([CYGWIN], [1], [Define a macro for Cygwin system])
+ AC_DEFINE([CYGWIN_ULLONG_TO_LDOUBLE_ROUND_PROBLEM], [1], [Define a macro for Cygwin (on XP only) where the compiler has rounding problem converting from unsigned long long to long double])
if test "X${enable_shared}" = "Xyes"; then
echo ' warning: shared libraries are not supported on Cygwin!'
echo ' disabling shared libraries'