summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-06-11 21:26:55 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-06-11 21:26:55 (GMT)
commitcfcbb212c85a7a098928ad8de20772be082aaa67 (patch)
tree0a9c8ff7d5a72557e912d4bdd9f822154696066e /configure.in
parent63ec41868180edbbc558a79e20355a85f14dc7e3 (diff)
downloadhdf5-cfcbb212c85a7a098928ad8de20772be082aaa67.zip
hdf5-cfcbb212c85a7a098928ad8de20772be082aaa67.tar.gz
hdf5-cfcbb212c85a7a098928ad8de20772be082aaa67.tar.bz2
[svn-r18991] Bug Fix: (ID 1921)
PHDF5 changed to use "mpiexec", instead of mpirun, as the default MPI applications startup command as defined in the MPI-2 definition, section 4.1. Note that only mpich related (using mpicc command) definitions are changed to mpiexec. Other favors like hcc, AIX, champion, are not changed since I don't have a way to verify them yet. Tested: jam and amani, using both current and new mpich. Did not h5committested since this affects PHDF5 configure only.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 20 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 8c6f539..681d7b2 100644
--- a/configure.in
+++ b/configure.in
@@ -683,7 +683,7 @@ dnl RUNSERIAL -- This is a command which will be prepended to
dnl the executable name to run the executable using
dnl a single process. For serial versions of the
dnl library this will normally be empty. For parallel
-dnl versions it might be something like `mpirun -np 1'.
+dnl versions it might be something like `mpiexec -n 1'.
dnl The value of this variable is substituted in *.in
dnl files.
dnl
@@ -692,7 +692,7 @@ dnl the executable name to run the executable on
dnl multiple processors. For the serial library the
dnl value will normally be the empty string. For
dnl parallel library it should be something like
-dnl `mpi -np $$NPROCS' where NPROCS will eventually
+dnl `mpiexec -n $$NPROCS' where NPROCS will eventually
dnl contain the number of processors on which to run
dnl the executable (the double dollarsigns are to
dnl protect the expansion until make executes the
@@ -708,15 +708,15 @@ dnl ----------------------------------------------------------------------
dnl If the compiler is obviously a parallel compiler then we're building
dnl a parallel version of hdf5 and should define HAVE_PARALLEL. Furthermore,
dnl the name of the compiler might tell us how to run the resulting
-dnl executable. For `mpicc' the executable should be run with `mpirun' from
+dnl executable. For `mpicc' the executable should be run with `mpiexec' from
dnl the same directory as mpicc if it exists.
dnl
case "$CC_BASENAME" in
mpicc)
- dnl The mpich compiler. Use mpirun from the same directory if it
+ dnl The mpich compiler. Use mpiexec from the same directory if it
dnl exists.
PARALLEL=mpicc
- AC_MSG_CHECKING([for mpirun])
+ AC_MSG_CHECKING([for mpiexec])
dnl Find the path where mpicc is located.
cmd="`echo $CC | cut -f1 -d' '`"
@@ -730,13 +730,13 @@ case "$CC_BASENAME" in
done
fi
- dnl Is there an mpirun at that path?
- if test -x $path/mpirun; then
- AC_MSG_RESULT([$path/mpirun])
+ dnl Is there an mpiexec at that path?
+ if test -x $path/mpiexec; then
+ AC_MSG_RESULT([$path/mpiexec])
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/mpirun -np \$\${NPROCS:=3}"
+ RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=3}"
fi
else
AC_MSG_RESULT([none])
@@ -813,7 +813,7 @@ dnl If the Fortran compiler is obviously a parallel compiler then we're
dnl building a parallel version of hdf5 and should define HAVE_PARALLEL.
dnl Furthermore, the name of the compiler might tell us how to run the
dnl resulting executable. For `mpif90' the executable should be run with
-dnl `mpirun' from the same directory as mpif90 if it exists.
+dnl `mpiexec' from the same directory as mpif90 if it exists.
dnl
if test "X$HDF_FORTRAN" = "Xyes"; then
dnl Change to the Fortran 90 language
@@ -821,10 +821,10 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
case "$FC" in
*mpif90*)
- dnl The Fortran mpich compiler. Use mpirun from the same directory
+ dnl The Fortran mpich compiler. Use mpiexec from the same directory
dnl if it exists.
PARALLEL=mpif90
- AC_MSG_CHECKING([for mpirun])
+ AC_MSG_CHECKING([for mpiexec])
dnl Find the path where mpif90 is located.
cmd=`echo $FC |cut -f1 -d' '`
@@ -838,13 +838,13 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
done
fi
- dnl Is there an mpirun at that path?
- if test -x $path/mpirun; then
- AC_MSG_RESULT([$path/mpirun])
+ dnl Is there an mpiexec at that path?
+ if test -x $path/mpiexec; then
+ AC_MSG_RESULT([$path/mpiexec])
RUNSERIAL="${RUNSERIAL:-none}"
if test -z "$RUNPARALLEL"; then
- RUNPARALLEL="$path/mpirun -np \$\${NPROCS:=2}"
+ RUNPARALLEL="$path/mpiexec -n \$\${NPROCS:=2}"
fi
else
AC_MSG_RESULT([none])
@@ -2633,9 +2633,9 @@ case "X-$enable_parallel" in
AC_LANG_POP(Fortran)
fi
- dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Set RUNPARALLEL to mpiexec if not set yet.
dnl Check for building on Cray if RUNPARALLEL is not yet set by checking
- dnl for 'aprun' command (which is the parallel job launcher, like mpirun).
+ dnl for 'aprun' command (which is the parallel job launcher, like mpiexec).
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
dnl Find the path where aprun is located.
for path in `echo $PATH | ${TR} ":" " "`; do
@@ -2646,9 +2646,9 @@ case "X-$enable_parallel" in
done
fi
- dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Set RUNPARALLEL to mpiexec if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
- RUNPARALLEL="mpirun -np \$\${NPROCS:=3}"
+ RUNPARALLEL="mpiexec -n \$\${NPROCS:=3}"
fi
;;