summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2011-06-28 21:25:10 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2011-06-28 21:25:10 (GMT)
commitd93ae2622696b383189113d5a1a138f8b0fa8380 (patch)
tree2ee5a8958916c20681c25bf190416171eead1122 /configure.in
parentd3a505abb7b4b90bbbcda3fcd3655141920861df (diff)
downloadhdf5-d93ae2622696b383189113d5a1a138f8b0fa8380.zip
hdf5-d93ae2622696b383189113d5a1a138f8b0fa8380.tar.gz
hdf5-d93ae2622696b383189113d5a1a138f8b0fa8380.tar.bz2
[svn-r21044] Purpose:
Fix HDFFV-7592 "Remove PACKEDBITS option from autotools files" Description: The code for h5dump's packed bits feature was conditionally compiled in via this option during its 'beta' release in 1.8.5. Now that the feature is fully supported, h5dump has since been changed to always compile the packed bits code (having removed the #ifdef H5_HAVE_H5DUMP_PACKED_BITS checks), so this option in configure is no longer needed. This commit removes the --enable-h5dump-packed-bits configure option, including the help summary from './configure --help' and the libhdf5.settings output summary, the PACKED_BITS Makefile variable, and the definition of H5_HAVE_H5DUMP_PACKED_BITS define in appropriate pubconf header files (which has already been removed from use in source code as of r20722). Note that this option was never added to the trunk, thus this commit only need occur on the 1.8 branch. Tested: - Configure output, help, & summary verified on jam - h5committested
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 0b4f74b..6bd2828 100644
--- a/configure.in
+++ b/configure.in
@@ -169,7 +169,6 @@ dnl STATIC_SHARED: whether static and/or shared libraries are requested.
dnl enable_shared: whether shared lib is enabled.
dnl enable_static: whether static lib is enabled.
dnl UNAME_INFO: System information.
-dnl PACKED_BITS: H5dump packed bits feature is enabled.
AC_SUBST(EXTERNAL_FILTERS)
AC_SUBST(MPE) MPE=no
@@ -190,7 +189,6 @@ AC_SUBST(STATIC_SHARED)
AC_SUBST(enable_shared)
AC_SUBST(enable_static)
AC_SUBST(UNAME_INFO) UNAME_INFO=`uname -a`
-AC_SUBST(PACKED_BITS) PACKED_BITS=yes
dnl ----------------------------------------------------------------------
dnl Some platforms have broken basename, and/or xargs programs. Check
@@ -4289,26 +4287,6 @@ AC_ARG_ENABLE([embedded-libinfo],
dnl ----------------------------------------------------------------------
-dnl Enable h5dump packed bits feature
-dnl
-AC_MSG_CHECKING([Whether to enable the h5dump packed bits feature])
-AC_ARG_ENABLE([h5dump-packed-bits],
- [AC_HELP_STRING([--enable-h5dump-packed-bits],
- [Enable h5dump packed bits feature [default=yes]])],
- [enable_h5dump_packed_bits=$enableval],
- [enable_h5dump_packed_bits=yes])
-
- if test "${enable_h5dump_packed_bits}" = "yes"; then
- AC_MSG_RESULT([yes])
- AC_DEFINE([HAVE_H5DUMP_PACKED_BITS], [1],
- [Define if h5dump packed bits feature is enabled])
- else
- AC_MSG_RESULT([no])
- PACKED_BITS=no
- fi
-
-
-dnl ----------------------------------------------------------------------
dnl Check if pointer alignments are enforced
dnl
AC_MSG_CHECKING([if alignment restrictions are strictly enforced])