summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2010-05-04 23:57:47 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2010-05-04 23:57:47 (GMT)
commitf20bd5f62411d6d45ce0dbea7ce9b45a022aa005 (patch)
tree5a443e2565a574d3922fba95dcf4fb7c2caa9970 /configure.in
parent7cb55dd05270a5c6df2e492c14490bc2ddd4dc41 (diff)
downloadhdf5-f20bd5f62411d6d45ce0dbea7ce9b45a022aa005.zip
hdf5-f20bd5f62411d6d45ce0dbea7ce9b45a022aa005.tar.gz
hdf5-f20bd5f62411d6d45ce0dbea7ce9b45a022aa005.tar.bz2
[svn-r18701] ID 1853:
Added the configure option --enable-h5dump-packed-bits for the h5dump optional feature. Tested: Jam (default and --disable-h5dump-packed-bits).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 605ba6c..eb0b8e3 100644
--- a/configure.in
+++ b/configure.in
@@ -167,6 +167,7 @@ dnl STATIC_SHARED: whether static and/or shared libraries are requested.
dnl enable_shared: whether shared lib is enabled.
dnl enable_static: whether static lib is enabled.
dnl UNAME_INFO: System information.
+dnl PACKED_BITS: H5dump packed bits feature is enabled.
AC_SUBST(EXTERNAL_FILTERS)
AC_SUBST(MPE) MPE=no
@@ -187,6 +188,7 @@ AC_SUBST(STATIC_SHARED)
AC_SUBST(enable_shared)
AC_SUBST(enable_static)
AC_SUBST(UNAME_INFO) UNAME_INFO=`uname -a`
+AC_SUBST(PACKED_BITS) PACKED_BITS=yes
dnl ----------------------------------------------------------------------
dnl Some platforms have broken basename, and/or xargs programs. Check
@@ -3948,6 +3950,26 @@ AC_ARG_ENABLE([embedded-libinfo],
dnl ----------------------------------------------------------------------
+dnl Enable h5dump packed bits feature
+dnl
+AC_MSG_CHECKING([Whether to enable the h5dump packed bits feature])
+AC_ARG_ENABLE([h5dump-packed-bits],
+ [AC_HELP_STRING([--enable-h5dump-packed-bits],
+ [Enable h5dump packed bits feature [default=yes]])],
+ [enable_h5dump_packed_bits=$enableval],
+ [enable_h5dump_packed_bits=yes])
+
+ if test "${enable_h5dump_packed_bits}" = "yes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_H5DUMP_PACKED_BITS], [1],
+ [Define if h5dump packed bits feature is enabled])
+ else
+ AC_MSG_RESULT([no])
+ PACKED_BITS=no
+ fi
+
+
+dnl ----------------------------------------------------------------------
dnl Check if pointer alignments are enforced
dnl
AC_MSG_CHECKING([if alignment restrictions are strictly enforced])