summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 17:06:48 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 17:06:48 (GMT)
commit11f088a44c03fc1a49b95ef2adc5654932df597b (patch)
tree8c96d68d120ae724ea1d26668b70f172ac4cc523 /configure.in
parentfbf7f470e2f8c29994829ada8b4c01590d4cacc7 (diff)
downloadhdf5-11f088a44c03fc1a49b95ef2adc5654932df597b.zip
hdf5-11f088a44c03fc1a49b95ef2adc5654932df597b.tar.gz
hdf5-11f088a44c03fc1a49b95ef2adc5654932df597b.tar.bz2
[svn-r17568] Purpose:
Configure Fix Description: Modified configure to set FC and CXX to "no" when fortran and c++ are not being compiled, respectively. This will prevent configure from running some checks on these compilers when they are not being used. This fixes a problem that was occuring when FC and/or CXX are set to a nonexistant or invalid compiler. Even if the languages were disabled, a libtool test would fail, thus preventing libtool from properly linking any libraries, yet configure would not flag an error message due to this because the languages were disabled. Tested: - h5committest (jam, smirom, linew) - manually eyeballed configure output and logfile.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 50a23b4..4210458 100644
--- a/configure.in
+++ b/configure.in
@@ -433,6 +433,7 @@ dnl compile the DOUBLE PRECISION interfaces.
AC_LANG_POP(Fortran)
else
echo "no"
+ FC="no"
fi
AM_CONDITIONAL([FORTRAN_HAVE_SIZEOF], [test "X$HAVE_SIZEOF" = "Xyes"])
@@ -559,6 +560,7 @@ int main(void) {
])
else
echo "no"
+ CXX="no"
fi
dnl Change back to the C language