summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-04-10 20:52:14 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-04-10 20:52:14 (GMT)
commit934d53254405a1fe5b87773d751d64e380470557 (patch)
tree3a85e17288ea27176582e83f220ad61d18e11bd4 /configure.in
parent19077b27d0885b9414a41e75cf7f5f151665e2ad (diff)
downloadhdf5-934d53254405a1fe5b87773d751d64e380470557.zip
hdf5-934d53254405a1fe5b87773d751d64e380470557.tar.gz
hdf5-934d53254405a1fe5b87773d751d64e380470557.tar.bz2
[svn-r14824] Purpose: Updating HDF5 1.8 to use automake 1.10.1 and libtool 2.2
Description: Updated bin/reconfigure script to reflect the new versions of libtool and automake in the /home1/packages/ directory. Rearranged configure.in script. For some reason, when using libtool 2.2, the libtool script doesn't generate until later in the configuration process, so I had to move a test that parsed through the libtool script to a point after where it was actually being generated. Ran libtoolize on the project, and ran bin/reconfigure to regenerate configure and Makefile.in's throughout. Tested: kagiso, smirom, linew, tg-login
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in63
1 files changed, 31 insertions, 32 deletions
diff --git a/configure.in b/configure.in
index 5551873..0eebd6e 100644
--- a/configure.in
+++ b/configure.in
@@ -871,8 +871,8 @@ esac
dnl ----------------------------------------------------------------------
dnl Create libtool. If shared/static libraries are going to be enabled
dnl or disabled, it should happen before these macros.
-AC_LIBTOOL_DLOPEN
-AM_PROG_LIBTOOL
+LT_PREREQ([2.2])
+LT_INIT([dlopen])
dnl Post processing to patch up some deficiencies in libtool (as of
dnl Libtool 1.5.14)
@@ -3462,36 +3462,6 @@ else
BYTESEX="little-endian"
fi
-dnl Are we compiling static libraries, shared libraries, or both? This
-dnl is only used for the libhdf5.settings file. We can't just look at
-dnl $enable_static and $enable_shared because if they're yes the ltconfig
-dnl might have decided that one or the other is simply not possible.
-dnl Therefore we have to ask the generated `libtool' shell script
-dnl which 'features' it has enabled.
-AC_SUBST([STATIC_SHARED])
-if (./libtool --features | grep '^enable shared libraries' > /dev/null); then
- enable_shared=yes
-else
- enable_shared=no
-fi
-
-if (./libtool --features | grep '^enable static libraries' > /dev/null); then
- enable_static=yes
-else
- enable_static=no
-fi
-
-if test "X$enable_static" = "Xyes" && test "X$enable_shared" = "Xyes"; then
- STATIC_SHARED="static, shared"
-elif test "X$enable_static" = "Xyes"; then
- STATIC_SHARED="static"
-elif test "X$enable_shared" = "Xyes"; then
- STATIC_SHARED="shared"
-else
- STATIC_SHARED="none"
-fi
-
-
dnl Parallel support? (set above except empty if none)
PARALLEL=${PARALLEL:-no}
@@ -3827,6 +3797,35 @@ touch ./config/stamp2
# Finally the makefiles
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
+dnl Are we compiling static libraries, shared libraries, or both? This
+dnl is only used for the libhdf5.settings file. We can't just look at
+dnl $enable_static and $enable_shared because if they're yes the ltconfig
+dnl might have decided that one or the other is simply not possible.
+dnl Therefore we have to ask the generated `libtool' shell script
+dnl which 'features' it has enabled.
+AC_SUBST([STATIC_SHARED])
+if (./libtool --features | grep '^enable shared libraries' > /dev/null); then
+ enable_shared=yes
+else
+ enable_shared=no
+fi
+
+if (./libtool --features | grep '^enable static libraries' > /dev/null); then
+ enable_static=yes
+else
+ enable_static=no
+fi
+
+if test "X$enable_static" = "Xyes" && test "X$enable_shared" = "Xyes"; then
+ STATIC_SHARED="static, shared"
+elif test "X$enable_static" = "Xyes"; then
+ STATIC_SHARED="static"
+elif test "X$enable_shared" = "Xyes"; then
+ STATIC_SHARED="shared"
+else
+ STATIC_SHARED="none"
+fi
+
chmod 755 tools/misc/h5cc
if test "X$HDF_FORTRAN" = "Xyes"; then