summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2009-04-20 23:03:40 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2009-04-20 23:03:40 (GMT)
commitbdb33e7c9880c61acc47bb0ea5bb3b0586f3c1ad (patch)
tree2b93c065dd8f024f5a3f312d62879bd1efe9f1f2 /configure.in
parentcd48d93298414e48d8aa5dc3dbd2c2701b152e2c (diff)
downloadhdf5-bdb33e7c9880c61acc47bb0ea5bb3b0586f3c1ad.zip
hdf5-bdb33e7c9880c61acc47bb0ea5bb3b0586f3c1ad.tar.gz
hdf5-bdb33e7c9880c61acc47bb0ea5bb3b0586f3c1ad.tar.bz2
[svn-r16813] New feature(Bug 230):
Embed the content of libhdf5.settings into the hdf5 executables so that an "orphaned" executables can display (via the Unix strings command, for example) the library settings used to build the executables. This is a prototype implementation. Much improvement is needed. configure.in: Added the --disable-embedded-libinfo option to disable this feature. configure: src/H5config.h.in: Generated by autotools like automake. src/H5detect.c: Implement insert_libhdf5_settings() to insert the contents of libhdf5.settings into the library as an extern string variable so that it is included in all HDF5 executable. Much improvement is needed. fortran/src/Makefile.in: Auto-generated by bin/reconfigure. (i.e., I did make any changes to cause its direct regeneration). Tested: Jam serial, using default and --disable-embedded-libinfo, configure options.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 95703e1..abaa92a 100644
--- a/configure.in
+++ b/configure.in
@@ -3806,6 +3806,25 @@ esac
dnl ----------------------------------------------------------------------
+dnl Enable embedded library information
+dnl
+AC_MSG_CHECKING([Whether to have library information embedded in the executables])
+AC_ARG_ENABLE([embedded-libinfo],
+ [AC_HELP_STRING([--enable-embedded-libinfo],
+ [Enable embedded library information [default=yes]])],
+ [enable_embedded_libinfo=$enableval],
+ [enable_embedded_libinfo=yes])
+
+ if test "${enable_embedded_libinfo}" = "yes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_EMBEDDED_LIBINFO], [1],
+ [Define if library information should be embedded in the executables])
+ else
+ AC_MSG_RESULT([no])
+ fi
+
+
+dnl ----------------------------------------------------------------------
dnl Check if pointer alignments are enforced
dnl
AC_MSG_CHECKING([if alignment restrictions are strictly enforced])