summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-08-31 15:28:10 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-08-31 15:28:10 (GMT)
commitee3ed7a67ff8a3d8a3ce2dac4e6942724ba33c85 (patch)
tree44745f201d341aae51163b31b89d378776de516a /configure.in
parent4f9b08427b90139c3d21d8f8d5742f29f9f2722d (diff)
downloadhdf5-ee3ed7a67ff8a3d8a3ce2dac4e6942724ba33c85.zip
hdf5-ee3ed7a67ff8a3d8a3ce2dac4e6942724ba33c85.tar.gz
hdf5-ee3ed7a67ff8a3d8a3ce2dac4e6942724ba33c85.tar.bz2
[svn-r17439] Purpose:
Updating autotools Description: Bring revisions 17345 and 17357 from trunk to 1.8, specifically: - Automake upgraded to 1.11 - Autoconf upgraded to 2.64 - bin/reconfigure script edited to use new versions (on jam), and run to generate new configure script and Makefile.in's. - configure.in script edited to add "_cv_" to all AC_CACHE_VAL strings (in order to comply with new autoconf standard). - bin/install-sh script replaced with new version as provided by automake. Tested: - All issues on trunk were resolved, so only tested on jam and linew. Any other outliers should be caught by daily tests.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 3007338..9ae6ae9 100644
--- a/configure.in
+++ b/configure.in
@@ -2696,7 +2696,7 @@ dnl bug also occurs at SGI IRIX 6.5 C with compiler version lower than or equal
dnl In case people still use the old compiler, we keep this flag.
AC_MSG_CHECKING([if irregular hyperslab optimization code works inside MPI-IO])
-AC_CACHE_VAL([hdf5_mpi_complex_derived_datatype_works],[hdf5_mpi_complex_derived_datatype_works=yes])
+AC_CACHE_VAL([hdf5_cv_mpi_complex_derived_datatype_works],[hdf5_mpi_complex_derived_datatype_works=yes])
if test ${hdf5_mpi_complex_derived_datatype_works} = "yes"; then
AC_DEFINE([MPI_COMPLEX_DERIVED_DATATYPE_WORKS], [1],
@@ -2715,7 +2715,7 @@ dnl and SGI altix. For those systems, we have to turn off this feature and use i
dnl
AC_MSG_CHECKING([if MPI-IO can do collective IO when one or more processes don't do IOs])
-AC_CACHE_VAL([hdf5_mpi_special_collective_io_works],[hdf5_mpi_special_collective_io_works=yes])
+AC_CACHE_VAL([hdf5_cv_mpi_special_collective_io_works],[hdf5_mpi_special_collective_io_works=yes])
if test ${hdf5_mpi_special_collective_io_works} = "yes"; then
AC_DEFINE([MPI_SPECIAL_COLLECTIVE_IO_WORKS], [1],
@@ -2844,7 +2844,7 @@ AC_ARG_ENABLE([direct-vfd],
[DIRECT_VFD=$enableval], [DIRECT_VFD=yes])
if test "$DIRECT_VFD" = "yes"; then
- AC_CACHE_VAL([hdf5_direct_io],
+ AC_CACHE_VAL([hdf5_cv_direct_io],
[AC_TRY_RUN([
#include <sys/types.h>
#include <sys/stat.h>
@@ -3004,7 +3004,7 @@ AC_MSG_CHECKING([if converting from long double to integers works])
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_integer_works=${hdf5_ldouble_to_integer_works=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_integer_works],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_integer_works],
[AC_TRY_RUN([
int main(void)
{
@@ -3071,7 +3071,7 @@ dnl the conversion to float.)
dnl
AC_MSG_CHECKING([if accurately converting unsigned long to float values])
-AC_CACHE_VAL([hdf5_ulong_to_float_accurate],
+AC_CACHE_VAL([hdf5_cv_ulong_to_float_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3204,7 +3204,7 @@ dnl than 0.5.
dnl
AC_MSG_CHECKING([if accurately roundup converting floating-point to unsigned long long values])
-AC_CACHE_VAL([hdf5_fp_to_ullong_accurate],
+AC_CACHE_VAL([hdf5_cv_fp_to_ullong_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3241,7 +3241,7 @@ dnl during conversion.
dnl
AC_MSG_CHECKING([if right maximum converting floating-point to unsigned long long values])
-AC_CACHE_VAL([hdf5_fp_to_ullong_right_maximum],
+AC_CACHE_VAL([hdf5_cv_fp_to_ullong_right_maximum],
[AC_TRY_RUN([
int main(void)
{
@@ -3286,7 +3286,7 @@ AC_MSG_CHECKING([if correctly converting long double to unsigned int values])
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_uint_accurate=${hdf5_ldouble_to_uint_accurate=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_uint_accurate],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_uint_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3488,7 +3488,7 @@ AC_MSG_CHECKING([if correctly converting long double to (unsigned) long long val
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_ldouble_to_llong_accurate=${hdf5_ldouble_to_llong_accurate=no}
else
- AC_CACHE_VAL([hdf5_ldouble_to_llong_accurate],
+ AC_CACHE_VAL([hdf5_cv_ldouble_to_llong_accurate],
[AC_TRY_RUN([
int main(void)
{
@@ -3549,7 +3549,7 @@ AC_MSG_CHECKING([if correctly converting (unsigned) long long to long double val
if test ${ac_cv_sizeof_long_double} = 0; then
hdf5_llong_to_ldouble_correct=${hdf5_llong_to_ldouble_correct=no}
else
- AC_CACHE_VAL([hdf5_llong_to_ldouble_correct],
+ AC_CACHE_VAL([hdf5_cv_llong_to_ldouble_correct],
[AC_TRY_RUN([
int main(void)
{