summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 17:05:38 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-01 17:05:38 (GMT)
commit8c754e83854574261328889b59681a6cab40e0c8 (patch)
tree301af72176067fa81cb5ed4d8dd0f7727762c65f /configure.in
parent98f6b609ad017d9bb8c018227060b7113a53b590 (diff)
downloadhdf5-8c754e83854574261328889b59681a6cab40e0c8.zip
hdf5-8c754e83854574261328889b59681a6cab40e0c8.tar.gz
hdf5-8c754e83854574261328889b59681a6cab40e0c8.tar.bz2
[svn-r17567] Purpose:
Configure Fix Description: Modified configure to set FC and CXX to "no" when fortran and c++ are not being compiled, respectively. This will prevent configure from running some checks on these compilers when they are not being used. This fixes a problem that was occuring when FC and/or CXX are set to a nonexistant or invalid compiler. Even if the languages were disabled, a libtool test would fail, thus preventing libtool from properly linking any libraries, yet configure would not flag an error message due to this because the languages were disabled. Tested: - h5committest (jam, smirom, linew) - manually eyeballed configure output and logfile.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index febb212..54ab501 100644
--- a/configure.in
+++ b/configure.in
@@ -433,6 +433,7 @@ dnl compile the DOUBLE PRECISION interfaces.
AC_LANG_POP(Fortran)
else
echo "no"
+ FC="no"
fi
AM_CONDITIONAL([FORTRAN_HAVE_SIZEOF], [test "X$HAVE_SIZEOF" = "Xyes"])
@@ -559,6 +560,7 @@ int main(void) {
])
else
echo "no"
+ CXX="no"
fi
dnl Change back to the C language