summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-11-10 19:56:04 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-11-10 19:56:04 (GMT)
commit911e79b273bddac85c698b77718516b8a8ee9ab2 (patch)
tree50541570407c04ef30d3c706de5ea75fd0993608 /configure.in
parent227a79d5513e305d047020d96b1ac8b4f8bf44b5 (diff)
downloadhdf5-911e79b273bddac85c698b77718516b8a8ee9ab2.zip
hdf5-911e79b273bddac85c698b77718516b8a8ee9ab2.tar.gz
hdf5-911e79b273bddac85c698b77718516b8a8ee9ab2.tar.bz2
[svn-r12887] A fix for linking issues.
Should disable linking against shared libraries in Fortran for compilers that don't support shared libraries. Should also fix problem when the wrong Fortran file extension was specified. If these changes don't solve the Daily Test issues, I'll look at backing out the autotool version change until I have time to fix them. Tested on heping, kagiso, juniper.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 8 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index ab0437d..b6ad467 100644
--- a/configure.in
+++ b/configure.in
@@ -316,7 +316,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
dnl --------------------------------------------------------------------
dnl Fortran source extention
dnl
- FC_SRCEXT=f90
+ AC_FC_SRCEXT([f90])
AC_SUBST([F9XSUFFIXFLAG])
AC_SUBST([FSEARCH_DIRS])
@@ -741,40 +741,31 @@ dnl Absoft 32bit Fortran 95 9.0
dnl HP F90 v2.4
dnl Intel Fortran Compiler 8.1
dnl If any of these compilers is being used, disable shared libraries for
-dnl Fortran.
-
-dnl Disable shared libraries in Fortran by default (sometimes libtool will
-dnl try to link against other shared libraries even though HDF5 is built
-dnl as a static library).
-H5_FORTRAN_SHARED="no"
-
-if test "X${HDF_FORTRAN}" = "Xyes" && test "X${enable_shared}" != "Xno"; then
+dnl Fortran. This prevents building shared libraries and also prevents
+dnl trying to link against shared libraries.
+if test "X${HDF_FORTRAN}" = "Xyes"; then
H5_FORTRAN_SHARED="yes"
if (${FC} -V 2>&1 | grep '^pgf90') > /dev/null; then
- echo " warning: shared libraries are not supported for pgf90!"
- echo " disabling shared Fortran libraries"
H5_FORTRAN_SHARED="no"
fi
if (${FC} -V 2>&1 | grep '^Intel(R) Fortran Compiler') > /dev/null; then
- echo " warning: shared libraries are not supported for ifort!"
- echo " disabling shared Fortran libraries"
H5_FORTRAN_SHARED="no"
fi
if (${FC} +version 2>&1 | grep '^HP F90') > /dev/null; then
- echo " warning: shared libraries are not supported for f90!"
- echo " disabling shared Fortran libraries"
H5_FORTRAN_SHARED="no"
fi
if (${FC} -V 2>&1 | grep '^Absoft') > /dev/null; then
- echo " warning: shared libraries are not supported for Absoft f95!"
- echo " disabling shared Fortran libraries"
H5_FORTRAN_SHARED="no"
fi
+ if test "X${enable_shared}" != "Xno" && test "X${H5_FORTRAN_SHARED}" = "Xno"; then
+ AC_MSG_WARN([shared libraries are not supported; disabling shared Fortran libraries])
+ fi
+
if test "X${enable_static}" = "Xno" && test "X${H5_FORTRAN_SHARED}" = "Xno"; then
AC_MSG_ERROR([both static and shared Fortran libraries are disabled])
fi