summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2007-06-02 18:19:36 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2007-06-02 18:19:36 (GMT)
commit1280f90f8128a72f1b2cfe45d3a5a24334c222e0 (patch)
treea7969815417facfd248292e2830679fd4fbea9df /configure.in
parent2aa1084117a0040dbb6c54246837cd3133f51bdf (diff)
downloadhdf5-1280f90f8128a72f1b2cfe45d3a5a24334c222e0.zip
hdf5-1280f90f8128a72f1b2cfe45d3a5a24334c222e0.tar.gz
hdf5-1280f90f8128a72f1b2cfe45d3a5a24334c222e0.tar.bz2
[svn-r13829] Some systems (only SGI Altix ProPack 4 discovered so far) doesn't return correct
file size from MPI_File_get_size. Bypass this problem by replacing it with stat. Add an option --disable-mpi-size in configure to indicate this function doesn't work properly. Add a test in testpar/t_mpi.c, too. If it returns wrong file size, print out a warning. Tested on kagiso (parallel) because already tested the same change to v1.6 on several platforms (kagiso, cobalt, copper, and sol).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 43cd698..994e739 100644
--- a/configure.in
+++ b/configure.in
@@ -2511,6 +2511,37 @@ if test -n "$PARALLEL"; then
fi
dnl ----------------------------------------------------------------------
+dnl Set the flag to indicate that the MPI_File_get_size() function
+dnl works. The default is enabled unless the user knows the function
+dnl doesn't work on the system and disables it. (This flag should be set
+dnl for all machines except for SGI Altix Propack 4 where the function
+dnl doesn't return correct file size.)
+dnl
+AC_ARG_ENABLE([mpi-size],
+ [AC_HELP_STRING([--enable-mpi-size],
+ [Some systems (only SGI Altix Propack 4 so far) return wrong value
+ from MPI_File_get_size. By disabling this function, the library
+ will replace it with stat to get the correct file size.
+ [default=yes]])],
+ [MPI_GET_SIZE=$enableval])
+
+AC_MSG_CHECKING([if MPI_File_get_size is enabled])
+
+AC_SUBST(MPI_GET_SIZE)
+case "X-$MPI_GET_SIZE" in
+ X-no)
+ AC_MSG_RESULT([no])
+ MPI_GET_SIZE=no
+ ;;
+ X-yes|*)
+ AC_MSG_RESULT([yes])
+ MPI_GET_SIZE=yes
+ AC_DEFINE([HAVE_MPI_GET_SIZE], [1],
+ [Define if MPI_File_get_size works correctly])
+ ;;
+esac
+
+dnl ----------------------------------------------------------------------
dnl Check to see whether the complicate MPI derived datatype works.
dnl In Dec. 20th, 2004, we found that IBM's MPIO implemention didn't
dnl handle with the displacement of the complicate MPI type derived datatype