summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2007-04-27 14:56:33 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2007-04-27 14:56:33 (GMT)
commit2b807f7fddc631d32bf324df654eb4db6c795233 (patch)
tree5b9c629fa06b31a7d0c142d8c876e45bcb771666 /configure.in
parent71c29a007fb7ee0cb9218255cdf4e393c1d22a6b (diff)
downloadhdf5-2b807f7fddc631d32bf324df654eb4db6c795233.zip
hdf5-2b807f7fddc631d32bf324df654eb4db6c795233.tar.gz
hdf5-2b807f7fddc631d32bf324df654eb4db6c795233.tar.bz2
[svn-r13703] Feature:
Change --enable-debug default to no if producton is enabled. Platform tested: kagiso just doing configure with various combinations of option and varified the output.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c52a386..56cbd9a 100644
--- a/configure.in
+++ b/configure.in
@@ -2027,6 +2027,7 @@ esac
dnl ----------------------------------------------------------------------
dnl Turn on debugging by setting compiler flags
+dnl This must come after the enable-production since it depends on production.
dnl
AC_MSG_CHECKING(for debug flags)
AC_ARG_ENABLE([debug],
@@ -2038,10 +2039,19 @@ AC_ARG_ENABLE([debug],
packages.])],
[DEBUG_PKG=$enableval])
+dnl Default to no if producton is enabled
+if test "X-$DEBUG_PKG" = X- ; then
+ if test "$enable_production" = yes ; then
+ DEBUG_PKG=no
+ else
+ DEBUG_PKG=yes
+ fi
+fi
+
AC_SUBST([DEBUG_PKG])
all_packages="ac,b,b2,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
- X-|X-yes)
+ X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
H5_CPPFLAGS="$H5_CPPFLAGS -UNDEBUG"
AC_MSG_RESULT([default ($DEBUG_PKG)])