summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-02 15:04:59 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-02 15:04:59 (GMT)
commit74457ab98c53d30923179318fc8b6b141627570e (patch)
tree5b7fea9634194b904c64ce7fd5b403c0795cd908 /configure.in
parent709654724bd8b7d148ddd977a835782f1fe8a2c6 (diff)
downloadhdf5-74457ab98c53d30923179318fc8b6b141627570e.zip
hdf5-74457ab98c53d30923179318fc8b6b141627570e.tar.gz
hdf5-74457ab98c53d30923179318fc8b6b141627570e.tar.bz2
[svn-r15577] Description:
Moved AM_CONDITIONAL([FORTRAN_HAVE_SIZEOF]....) outside of Fortran conditional loop so that the value gets registered regardless of whether Fortran is enabled.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 8e9782b..9c04f7a 100644
--- a/configure.in
+++ b/configure.in
@@ -318,6 +318,10 @@ AC_ARG_ENABLE([fortran],
[Compile the Fortran interface [default=no]])],
[HDF_FORTRAN=$enableval])
+
+HAVE_SIZEOF="no"
+FORTRAN_DEFAULT_REALisDBLE="no"
+
if test "X$HDF_FORTRAN" = "Xyes"; then
echo "yes"
@@ -385,20 +389,17 @@ dnl --------------------------------------------------------------------
dnl See if the fortran compiler supports the intrinsic function "SIZEOF"
AC_MSG_CHECKING([if Fortran compiler supports intrinsic SIZEOF])
-
- HAVE_SIZEOF="no"
AC_TRY_COMPILE(,[
i = sizeof(x)
], [AC_MSG_RESULT(yes)
HAVE_SIZEOF="yes"],
AC_MSG_RESULT(no))
- AM_CONDITIONAL([FORTRAN_HAVE_SIZEOF], [test "X$HAVE_SIZEOF" = "Xyes"])
+
dnl Check to see if -r8 was specified to determine if we need to
dnl compile the DOUBLE PRECISION interfaces.
- FORTRAN_DEFAULT_REALisDBLE="no"
AC_MSG_CHECKING([if Fortran default REAL is DOUBLE PRECISION])
AC_TRY_RUN([
@@ -432,6 +433,7 @@ else
echo "no"
fi
+AM_CONDITIONAL([FORTRAN_HAVE_SIZEOF], [test "X$HAVE_SIZEOF" = "Xyes"])
AM_CONDITIONAL([FORTRAN_DEFAULT_REALisDBLE_F], [test "X$FORTRAN_DEFAULT_REALisDBLE" = "Xyes"])
dnl ----------------------------------------------------------------------