summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-01 15:25:02 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-01 15:25:02 (GMT)
commita66c8bf293d573276250ea4910509a57891c384b (patch)
treee82e5ed7c14ef0d7c268f5cd92738ec24dcced63 /configure.in
parent529585c757a4bb3d902a707feba81aff1cf59ebf (diff)
downloadhdf5-a66c8bf293d573276250ea4910509a57891c384b.zip
hdf5-a66c8bf293d573276250ea4910509a57891c384b.tar.gz
hdf5-a66c8bf293d573276250ea4910509a57891c384b.tar.bz2
[svn-r15570] Description:
Added a test for the availability of intrinsic Fortran function SIZEOF. Sets the global variable FORTRAN_HAVE_SIZEOF depending if SIZEOF is available.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fffb0f2..8e9782b 100644
--- a/configure.in
+++ b/configure.in
@@ -381,6 +381,21 @@ dnl ], AC_MSG_RESULT(yes),
dnl AC_MSG_RESULT(no)
dnl FCFLAGS="$FCFLAGS_saved")
+dnl --------------------------------------------------------------------
+dnl See if the fortran compiler supports the intrinsic function "SIZEOF"
+
+ AC_MSG_CHECKING([if Fortran compiler supports intrinsic SIZEOF])
+
+ HAVE_SIZEOF="no"
+ AC_TRY_COMPILE(,[
+ i = sizeof(x)
+ ], [AC_MSG_RESULT(yes)
+ HAVE_SIZEOF="yes"],
+ AC_MSG_RESULT(no))
+ AM_CONDITIONAL([FORTRAN_HAVE_SIZEOF], [test "X$HAVE_SIZEOF" = "Xyes"])
+
+dnl Check to see if -r8 was specified to determine if we need to
+dnl compile the DOUBLE PRECISION interfaces.
FORTRAN_DEFAULT_REALisDBLE="no"