summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2012-03-26 20:26:06 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2012-03-26 20:26:06 (GMT)
commit086035bedefa3b318a18a34eaf3c2a3873af0822 (patch)
tree50c0bc9144fd30d9b58cffe17546ec7edef9d8e2 /configure.in
parent4d7d1ab871ac5b98b8560f38fba2fad9b9d2e00c (diff)
downloadhdf5-086035bedefa3b318a18a34eaf3c2a3873af0822.zip
hdf5-086035bedefa3b318a18a34eaf3c2a3873af0822.tar.gz
hdf5-086035bedefa3b318a18a34eaf3c2a3873af0822.tar.bz2
[svn-r22149] Purpose:
HDFFV-944: Fortran test problem with HDF5 182, intel 11.0, open-mpi-1.2.8 Description: Moved libtool post-processing 'ed' snippet that replaces wl="" with wl="-Wl," when intel compilers are used to the end of the configure script, after libtool is actually generated. (I imagine that at some point in time during a libtool version upgrade the libtool script ceased being generated immediately after the libtool initialization macro and is generated at the end of configure with all other files). Additionally, added a leading 'g' to the replacement invocation to change all instances of wl="" to wl="-Wl," instead of just the first that it comes across. (There's a separate one for each compiler used (C, Fortran, C++)). Tested: Reproduced the reported make failure and tested resolution on NCSA's Forge with OpenMPI built with Intel 12.0.4. Also, h5committested.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 17 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index 8854177..b53d57c 100644
--- a/configure.in
+++ b/configure.in
@@ -1027,24 +1027,6 @@ dnl or disabled, it should happen before these macros.
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL
-dnl Post processing to patch up some deficiencies in libtool (as of
-dnl Libtool 1.5.14)
-case $host_os in
- linux* | freebsd* )
- # If gcc is not used, need to set $wl to use "-Wl,"
- if $CC -v 2>&1 | grep '^gcc' > /dev/null ; then
- : using gcc
- else
- echo 'fixing $wl in' $ofile
-ed - $ofile <<EOF 2> /dev/null
-/^wl=""/s//wl="-Wl,"/
-w
-q
-EOF
- fi
- ;;
-esac
-
dnl ----------------------------------------------------------------------
dnl Check if we should install only statically linked executables.
dnl This check needs to occur after libtool is initialized because
@@ -4470,6 +4452,23 @@ touch ./config/stamp2
# Finally the makefiles
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
+dnl Post processing to patch up some deficiencies in libtool
+case $host_os in
+ linux* | freebsd* )
+ # If gcc is not used, need to set $wl to use "-Wl,"
+ if $CC -v 2>&1 | grep '^gcc' > /dev/null ; then
+ : using gcc
+ else
+ echo 'fixing $wl in' $ofile
+ed - $ofile <<EOF 2> /dev/null
+g/^wl=""/s//wl="-Wl,"/
+w
+q
+EOF
+ fi
+ ;;
+esac
+
dnl Are we compiling static libraries, shared libraries, or both? This
dnl is only used for the libhdf5.settings file. We can't just look at
dnl $enable_static and $enable_shared because if they're yes the ltconfig