summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2011-08-25 22:02:21 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2011-08-25 22:02:21 (GMT)
commita69cfa6bf218aed1ca2aeba5a4f042c88652fc99 (patch)
treeaa677186075b5620c8f037ff8e6234a621e33c02 /configure.in
parentfd71d209dfcd392686b464313f38a469167c2aa3 (diff)
downloadhdf5-a69cfa6bf218aed1ca2aeba5a4f042c88652fc99.zip
hdf5-a69cfa6bf218aed1ca2aeba5a4f042c88652fc99.tar.gz
hdf5-a69cfa6bf218aed1ca2aeba5a4f042c88652fc99.tar.bz2
[svn-r21315] Fix for fortran 2003-related bin/reconfigure warnings (with proper quoting this time). Tested on jam (w/ gfortran 4.5.3 for fortran 2003), talwit and linew.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 6c6bef5..01a2f41 100644
--- a/configure.in
+++ b/configure.in
@@ -529,11 +529,10 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_MSG_CHECKING([if Fortran compiler supports ISO_C_BINDING module])
- AC_TRY_COMPILE(,[
- USE iso_c_binding
- ], [AC_MSG_RESULT(yes)
- HAVE_ISO_C_BINDING="yes"],
- AC_MSG_RESULT(no))
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[USE iso_c_binding])],
+ [AC_MSG_RESULT(yes)
+ HAVE_ISO_C_BINDING=[yes]],
+ [AC_MSG_RESULT(no)])
if test "X$HAVE_ISO_C_BINDING" = "Xno"; then
AC_MSG_ERROR([Fortran compiler does not have ISO_C_BINDING; unsupported Fortran 2003 compiler, remove --enable-fortran2003])