summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-09-01 20:38:18 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-09-01 20:38:18 (GMT)
commit30c61d0f254d8201e9f84ee45f15fb83ee5f4495 (patch)
treea408aa22357a2cf2a2f57d941ee9a4431f073c02 /configure.in
parentc7808fa57eb9923b15d06e170dda140e72139ab8 (diff)
downloadhdf5-30c61d0f254d8201e9f84ee45f15fb83ee5f4495.zip
hdf5-30c61d0f254d8201e9f84ee45f15fb83ee5f4495.tar.gz
hdf5-30c61d0f254d8201e9f84ee45f15fb83ee5f4495.tar.bz2
[svn-r11335] Purpose:
Bug fix Description: configure used 'uname -o' to detect Cygwin. This command is fine on Cygwin, but causes errors on some other platforms (sol). Fixed this. Solution: Used 'uname' with no -o option to identify Cygwin. Platforms tested: mir, cygwin (on finrod)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index a4e659e..3b705b1 100644
--- a/configure.in
+++ b/configure.in
@@ -761,11 +761,15 @@ AC_CHECK_HEADERS([stddef.h setjmp.h features.h])
AC_CHECK_HEADERS([stdint.h], [C9x=yes])
dnl Windows
-if test "`uname -o`" = "Cygwin"; then
- AC_CHECK_HEADERS([io.h sys/timeb.h])
-else
- AC_CHECK_HEADERS([io.h winsock.h sys/timeb.h])
-fi
+case "`uname`" in
+ CYGWIN*)
+ AC_CHECK_HEADERS([io.h sys/timeb.h])
+ ;;
+ *)
+ AC_CHECK_HEADERS([io.h winsock.h sys/timeb.h])
+ ;;
+esac
+
case "$host" in
alpha*-dec*-osf*)
dnl The <sys/sysinfo.h> and <sys/proc.h> are needed on the DEC