summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2005-07-23 01:55:12 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2005-07-23 01:55:12 (GMT)
commit34bd25f361f81efc396314528f1824fe63af494e (patch)
tree0fa0ec3c102abac15cd4f1012b99941fdf703009 /configure.in
parent138d4f52544af96770b4a5f151a7b64f2c4dc922 (diff)
downloadhdf5-34bd25f361f81efc396314528f1824fe63af494e.zip
hdf5-34bd25f361f81efc396314528f1824fe63af494e.tar.gz
hdf5-34bd25f361f81efc396314528f1824fe63af494e.tar.bz2
[svn-r11144] Purpose:
New port Description: Elena asked me to check in her NEC SX-6 work, so here it is! :-) Platforms tested: FreeBSD 4.11 (sleipnir) NEC SX-6 (by Elena)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6b3e08c..eff7977 100644
--- a/configure.in
+++ b/configure.in
@@ -2382,6 +2382,10 @@ dnl Other HP-UX systems are unknown yet. (1/8/05 - SLU)
AC_MSG_CHECKING([if accurately converting from long double to integers works])
+if test ${ac_cv_sizeof_long_double}=0; then
+ hdf5_cv_sw_ldouble_to_integer_works=${hdf5_cv_sw_ldouble_to_integer_works=no}
+fi
+
AC_CACHE_VAL([hdf5_cv_sw_ldouble_to_integer_works],
[AC_TRY_RUN([
int main(void)
@@ -2423,6 +2427,12 @@ dnl incorrect and its cache value is set "no" in its config/irix6.x and
dnl irix5.x)
dnl
AC_MSG_CHECKING([if accurately converting from integers to long double works])
+
+if test ${ac_cv_sizeof_long_double}=0; then
+ hdf5_cv_sw_integer_to_ldouble_works=${hdf5_cv_sw_integer_to_ldouble_works=no}
+fi
+
+
AC_CACHE_VAL([hdf5_cv_sw_integer_to_ldouble_works], [hdf5_cv_sw_integer_to_ldouble_works=yes])
if test ${hdf5_cv_sw_integer_to_ldouble_works} = "yes"; then
@@ -2605,6 +2615,10 @@ dnl all machines, except for some Intel compilers on some Linux.)
dnl
AC_MSG_CHECKING([if converting long double to unsigned int values works])
+if test ${ac_cv_sizeof_long_double}=0; then
+ hdf5_cv_ldouble_to_uint_works=${hdf5_cv_ldouble_to_uint_works=no}
+fi
+
AC_CACHE_VAL([hdf5_cv_ldouble_to_uint_works],
[AC_TRY_RUN([
int main(void)
@@ -2674,6 +2688,11 @@ dnl where the last 2 bytes of mantissa are lost when compiler tries to do
dnl the conversion, and Cygwin where compiler doesn't do rounding correctly.)
dnl
AC_MSG_CHECKING([if converting unsigned long long to long double with precision work])
+
+if test ${ac_cv_sizeof_long_double}=0; then
+ hdf5_cv_ullong_to_ldouble_precision_works=${hdf5_cv_ullong_to_ldouble_precision_works=no}
+fi
+
AC_CACHE_VAL([hdf5_cv_ullong_to_ldouble_precision_works],
[AC_TRY_RUN([
int main(void)