summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-03-02 01:01:45 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-03-02 01:01:45 (GMT)
commit921d331fc8bd9cb5f5d855be8cd44cba4af0307a (patch)
tree2043f14ee45fa133f197c0f82d3cced7131f869e /configure.in
parent7baf33d19bcb13d1ed37f1216203da6f6b1a6750 (diff)
downloadhdf5-921d331fc8bd9cb5f5d855be8cd44cba4af0307a.zip
hdf5-921d331fc8bd9cb5f5d855be8cd44cba4af0307a.tar.gz
hdf5-921d331fc8bd9cb5f5d855be8cd44cba4af0307a.tar.bz2
[svn-r10114] Purpose:
Bug fix Description: Libtool simply doesn't seem to support shared libraries for pgcc, but tries to build them anyway. Solution: Edited configure to disable shared libraries in libtool script when pgcc is being used. This is a more drastic fix than the problem requires, but it is difficult to detect when this problem will occur. There is discussion online about shared libraries with pgcc, so hopefully libtool will support pgcc and this fix will become unneccesary. Platforms tested: sol, copper, mir, sleipnir Misc. update:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3f613be..cd65d87 100644
--- a/configure.in
+++ b/configure.in
@@ -477,6 +477,21 @@ EOF
;;
esac
+dnl As of Libtool 1.5.14, libtool officially doesn't know how to create
+dnl shared libraries with pgcc. In fact, it is able to do so on a number
+dnl of platforms, but not all (e.g., pgcc 5.2-4 on mir). There is discussion
+dnl online which will hopefully resolve this issue, but in the meantime
+dnl we disable support for shared libraries using pgcc because this issue
+dnl is difficult to detect. -JL 03/2005
+if (${CC-cc} -V 2>&1 | grep '^pgcc') > /dev/null; then
+ echo 'disabling shared libraries for pgcc'
+ed - $ofile <<EOF 2> /dev/null
+/^build_libtool_libs=yes/s//build_libtool_libs=no/
+w
+q
+EOF
+fi
+
dnl Fix up the INSTALL macro if it's a relative path. We want the
dnl full-path to the binary instead.
case "$INSTALL" in