summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2005-07-05 19:08:58 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2005-07-05 19:08:58 (GMT)
commitac75ce4141e000ce3a32e02710ae9b9f2a1fbe7f (patch)
treec03450a25b2e7474e0f649e5518e5c8434d1d0f5 /configure.in
parent7c7a856c5fe4091636c0b6a58a0d841bda5cefce (diff)
downloadhdf5-ac75ce4141e000ce3a32e02710ae9b9f2a1fbe7f.zip
hdf5-ac75ce4141e000ce3a32e02710ae9b9f2a1fbe7f.tar.gz
hdf5-ac75ce4141e000ce3a32e02710ae9b9f2a1fbe7f.tar.bz2
[svn-r11019] Purpose: Add detection
Description: pgcc version 6.0x have optimization (-O, -O2, or -O3) problem. It caused multi driver test to fail. The problem happened in a macro definition. Solution: Detect these versions and add option "-Mx,28,0x8" to the compiler to avoid the problem if optimization is enable. Platforms tested: mir and fuss - simple change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 020e8a5..4967361 100644
--- a/configure.in
+++ b/configure.in
@@ -534,6 +534,15 @@ q
EOF
fi
+dnl ----------------------------------------------------------------------
+dnl pgcc version 6.0x have optimization (-O, -O2 or -O3) problem. Detect
+dnl these versions and add option "-Mx,28,0x8" to the compiler to avoid
+dnl the problem if optimization is enable.
+dnl
+if (${CC-cc} -V 2>&1 | grep '^pgcc 6.0') > /dev/null && test "X$enable_production" = "Xyes"; then
+ CC="${CC-cc} -Mx,28,0x8"
+fi
+
dnl Fix up the INSTALL macro if it's a relative path. We want the
dnl full-path to the binary instead.
case "$INSTALL" in