summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-03-07 22:51:34 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-03-07 22:51:34 (GMT)
commit30e5df679c46bfeb5c9e6e0147f6dafae970df71 (patch)
tree22a30dd2231d23d9f1f923a3764026ff3efbda17 /configure.in
parent084c4ea9ee459564ee71ca7f57ca97798f0b34a0 (diff)
downloadhdf5-30e5df679c46bfeb5c9e6e0147f6dafae970df71.zip
hdf5-30e5df679c46bfeb5c9e6e0147f6dafae970df71.tar.gz
hdf5-30e5df679c46bfeb5c9e6e0147f6dafae970df71.tar.bz2
[svn-r5047] Purpose:
Bug Fix Description: Didn't need to test that the Pablo library had a function in it only that it was there. Solution: Removed that check. Just checked if we can actually find the physical library and include files where the user tells us they're hiding. Platforms tested: Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 22 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 346eb7b..f4fa0bf 100644
--- a/configure.in
+++ b/configure.in
@@ -783,18 +783,15 @@ AC_ARG_WITH(pablo,
[ --with-pablo[=DIR] Use the Pablo library [default=no]],,
withval=no)
+AC_MSG_CHECKING(for Pablo)
+
case "$withval" in
yes)
- failed="no"
- AC_CHECK_LIB(PabloTraceExt, initIOTrace,, failed="yes")
-
- if test "$failed" != "yes"; then
- HAVE_PABLO="yes"
- PABLO="pablo"
- fi
+ AC_MSG_RESULT(yes)
+ HAVE_PABLO="yes"
+ PABLO="pablo"
;;
no)
- AC_MSG_CHECKING(for Pablo)
AC_MSG_RESULT(suppressed)
;;
*)
@@ -822,9 +819,17 @@ case "$withval" in
fi
failed="no"
- AC_CHECK_HEADERS(IOTrace.h,
- AC_CHECK_LIB(PabloTraceExt, initIOTrace,, failed="yes"),
- failed="yes")
+ if test -f "$pablo_inc/PabloTrace.h"; then
+ :
+ else
+ failed="yes"
+ fi
+
+ if test -f "$pablo_lib/libPabloTraceExt.a"; then
+ :
+ else
+ failed="yes"
+ fi
if test "$failed" = "yes"; then
dnl Reset flags if failed
@@ -834,6 +839,12 @@ case "$withval" in
HAVE_PABLO="yes"
PABLO="pablo"
fi
+
+ if test "$HAVE_PABLO" = "yes"; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
;;
esac