summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2002-08-19 20:28:05 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2002-08-19 20:28:05 (GMT)
commit45a34cf267b823c6f1b62cce215b38546c18a031 (patch)
tree5466b2bfb4bab75cc2a460172cc9005cd9b2bbab /configure.in
parentcf834c832e8dc671948c42154ab2dbf616c76702 (diff)
downloadhdf5-45a34cf267b823c6f1b62cce215b38546c18a031.zip
hdf5-45a34cf267b823c6f1b62cce215b38546c18a031.tar.gz
hdf5-45a34cf267b823c6f1b62cce215b38546c18a031.tar.bz2
[svn-r5878] Purpose:
fix/feature Description: v1.4's configure had enable-trace default as on. That is not right for production code as it increase the object code and uses up compute time. Changed --enable-trace default to depend on --enable-debug. If debug is on, trace is on. Otherwise it is off. Also added the printing of CFLAGS, CPPFLAGS, and LDFLAGS in the summary. Platforms tested: eirene, arabica (pp).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in57
1 files changed, 37 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index d2aaba7..2b4483d 100644
--- a/configure.in
+++ b/configure.in
@@ -1427,24 +1427,36 @@ fi
dnl ----------------------------------------------------------------------
dnl Enable tracing of the API
+dnl This must come after the enable-debug since it depends on debug.
dnl
-AC_MSG_CHECKING([for API tracing])
+AC_MSG_CHECKING(for API tracing);
AC_ARG_ENABLE([trace],
- [AC_HELP_STRING([--disable-trace],
- [Disable API tracing capability])],
- [TRACE=$enableval])
-
-AC_SUBST([TRACE_API])
-
-if test -z "$TRACE" -o "X$TRACE" = "Xyes"; then
- AC_MSG_RESULT([yes])
- TRACE_API=yes
- CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
-else
- AC_MSG_RESULT([no])
- TRACE_API=no
- CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
+ [AC_HELP_STRING([--enable-trace],
+ [Enable API tracing capability.
+ Default=no if debug is disabled.])],
+ TRACE=$enableval)
+
+AC_SUBST(TRACE_API)
+dnl Default to no if debug is disabled
+if test "X-$TRACE" = X- ; then
+ if test -z "$DEBUG_PKG" ; then
+ TRACE=no
+ else
+ TRACE=yes
+ fi
fi
+case "X-$TRACE" in
+ X-yes)
+ AC_MSG_RESULT(yes)
+ TRACE_API=yes
+ CPPFLAGS="$CPPFLAGS -DH5_DEBUG_API"
+ ;;
+ X-no|*)
+ AC_MSG_RESULT(no)
+ TRACE_API=no
+ CPPFLAGS="$CPPFLAGS -UH5_DEBUG_API"
+ ;;
+esac
dnl Checkpoint the cache
AC_CACHE_SAVE
@@ -2023,6 +2035,15 @@ case "X-$enable_production" in
*) PRINT "$enable_production" ;;
esac
+PRINT_N " CFLAGS"
+PRINT "$CFLAGS"
+
+PRINT_N " CPPFLAGS"
+PRINT "$CPPFLAGS"
+
+PRINT_N " LDFLAGS"
+PRINT "$LDFLAGS"
+
PRINT_N " Debug Mode"
if test "X$DEBUG_PKG" = "X$all_packages"; then
@@ -2043,11 +2064,7 @@ PRINT_N " Statically Linked Executables"
IF_YES_NO "$STATIC_EXEC"
PRINT_N " Tracing"
-if test -z "$TRACE" -o "X$TRACE" = "Xyes"; then
- PRINT "Yes"
-else
- PRINT "No"
-fi
+IF_YES_NO "$TRACE_API"
PRINT "Languages:"