summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-08-08 20:39:02 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-08-08 20:39:02 (GMT)
commit573675e071a05bcc06636cbbfea72e9db3a9add2 (patch)
treea762143f17cf6a7c68d6737e3904413781330cdf /configure.in
parent6680e94aebf3f7b2929c740c7951b4bcf3f9b555 (diff)
downloadhdf5-573675e071a05bcc06636cbbfea72e9db3a9add2.zip
hdf5-573675e071a05bcc06636cbbfea72e9db3a9add2.tar.gz
hdf5-573675e071a05bcc06636cbbfea72e9db3a9add2.tar.bz2
[svn-r5844] Purpose:
Small Coding Change Description: Zeroed out the MPI_Status structure in one of our tests to determine if MPI_Get_count() works on the machine or not. This is similar to what we do in the library code to the status...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5230787..6b7e9ee 100644
--- a/configure.in
+++ b/configure.in
@@ -1697,6 +1697,7 @@ int main(int argc, char **argv)
int bytes_read = 0, ret;
MPI_Init(&argc, &argv);
+ memset(&mpi_stat, 0, sizeof(MPI_Status)); /* zero out status */
ret = MPI_Get_count(&mpi_stat, MPI_BYTE, &bytes_read);
MPI_Finalize();