summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-04-02 22:08:23 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-04-02 22:08:23 (GMT)
commit68556658dbb72d887d4bf29fb9d9f779c9f99806 (patch)
treee80226e35f40763dac621521dd174b5292759ca9 /configure.in
parent8005e831a03dcceec4b3333b5c5483a4cea3707c (diff)
downloadhdf5-68556658dbb72d887d4bf29fb9d9f779c9f99806.zip
hdf5-68556658dbb72d887d4bf29fb9d9f779c9f99806.tar.gz
hdf5-68556658dbb72d887d4bf29fb9d9f779c9f99806.tar.bz2
[svn-r5132] Purpose:
Autotools Update Description: I've updated autoconf, automake, and libtool to the latest/greatest versions; 2.53, 1.6, and 1.4.2 resp. Many changes come with the new versions: - ltconfig is no longer used - acconfig.h is no longer used (#define values are declared with the macro) - regeneration of all of the aclocal.m4, configure, and H5config.h.in files. - new config.{guess,sub} files - new ltmain.sh file Platforms tested: AIX (blue), and Linux
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in70
1 files changed, 44 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index 3bd9390..b5cf493 100644
--- a/configure.in
+++ b/configure.in
@@ -110,7 +110,8 @@ case $HSIZET in
*)
AC_MSG_RESULT(large)
HSIZET=large
- AC_DEFINE(HAVE_LARGE_HSIZET)
+ AC_DEFINE(HAVE_LARGE_HSIZET, 1,
+ [Define if it's safe to use \`long long' for hsize_t and hssize_t])
;;
esac
@@ -452,10 +453,6 @@ case "$host" in
;;
esac
-dnl ----------------------------------------------------------------------
-dnl Test for 64bit stuff before the data types and their sizes. The
-dnl result could effect the outcome of the sizeof macros below.
-dnl
case "$host_cpu-$host_vendor-$host_os" in
*linux*)
dnl ----------------------------------------------------------------------
@@ -588,7 +585,9 @@ AC_TRY_COMPILE([
#endif
],
[dev_t d1, d2; if(d1==d2) return 0;],
- AC_DEFINE(DEV_T_IS_SCALAR) AC_MSG_RESULT(yes),
+ AC_DEFINE(DEV_T_IS_SCALAR, 1,
+ [Define if \`dev_t' is a scalar])
+ AC_MSG_RESULT(yes),
AC_MSG_RESULT(no)
)
@@ -841,7 +840,8 @@ case "$withval" in
esac
if test -n "$GASS"; then
- AC_DEFINE(HAVE_GASS)
+ AC_DEFINE(HAVE_GASS, 1,
+ [Define if the Globus GASS is defined])
fi
dnl ----------------------------------------------------------------------
@@ -904,7 +904,8 @@ case "$withval" in
esac
if test -n "$SRB"; then
- AC_DEFINE(HAVE_SRB)
+ AC_DEFINE(HAVE_SRB, 1,
+ [Define if the SRB is defined])
fi
dnl ----------------------------------------------------------------------
@@ -1000,7 +1001,8 @@ case "X-$THREADSAFE" in
esac
if test "X$THREADSAFE" = "Xyes"; then
- AC_DEFINE(HAVE_THREADSAFE)
+ AC_DEFINE(HAVE_THREADSAFE, 1,
+ [Define if we have thread safe support])
fi
dnl ----------------------------------------------------------------------
@@ -1015,7 +1017,8 @@ AC_ARG_ENABLE(hdf5v1_4,
if test "$HDF5_V1_4_COMPAT" = "yes"; then
AC_MSG_RESULT(yes)
- AC_DEFINE(WANT_H5_V1_4_COMPAT)
+ AC_DEFINE(WANT_H5_V1_4_COMPAT, 1,
+ [Define if the HDF5 v1.4 compatibility functions are to be compiled in])
else
AC_MSG_RESULT(no)
fi
@@ -1031,7 +1034,8 @@ AC_ARG_ENABLE(stream-vfd,
if test "$STREAM_VFD" = "yes"; then
AC_MSG_RESULT(yes)
AC_CHECK_HEADERS(netinet/tcp.h sys/filio.h)
- AC_DEFINE(HAVE_STREAM)
+ AC_DEFINE(HAVE_STREAM, 1,
+ [Define if the stream virtual file driver should be compiled])
dnl Check if 'socklen_t' available
AC_MSG_CHECKING([if socklen_t is defined])
@@ -1049,7 +1053,9 @@ if test "$STREAM_VFD" = "yes"; then
#endif
],
[socklen_t foo; return 0;],
- AC_DEFINE(HAVE_SOCKLEN_T) AC_MSG_RESULT(yes),
+ AC_DEFINE(HAVE_SOCKLEN_T, 1,
+ [Define if \`socklen_t' is defined])
+ AC_MSG_RESULT(yes),
AC_MSG_RESULT(no)
)
else
@@ -1066,7 +1072,8 @@ AC_MSG_CHECKING(for tm_gmtoff in struct tm)
AC_TRY_COMPILE([
#include <sys/time.h>
#include <time.h>],[struct tm tm; tm.tm_gmtoff=0;],
-AC_DEFINE(HAVE_TM_GMTOFF)
+AC_DEFINE(HAVE_TM_GMTOFF, 1,
+ [Define if \`tm_gmtoff' is a member of \`struct tm'])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
@@ -1075,7 +1082,8 @@ AC_MSG_CHECKING(for __tm_gmtoff in struct tm)
AC_TRY_COMPILE([
#include <sys/time.h>
#include <time.h>],[struct tm tm; tm.__tm_gmtoff=0;],
-AC_DEFINE(HAVE___TM_GMTOFF)
+AC_DEFINE(HAVE___TM_GMTOFF, 1,
+ [Define if \`__tm_gmtoff' is a member of \`struct tm'])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
@@ -1084,7 +1092,8 @@ AC_MSG_CHECKING(for global timezone variable)
AC_TRY_LINK([
#include <sys/time.h>
#include <time.h>], [timezone=0;],
-AC_DEFINE(HAVE_TIMEZONE)
+AC_DEFINE(HAVE_TIMEZONE, 1,
+ [Define if \`timezone' is a global variable])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
@@ -1095,7 +1104,8 @@ AC_TRY_COMPILE([
#include <sys/types.h>
#include <sys/time.h>
#include <time.h>],[struct timezone tz; tz.tz_minuteswest=0;],
-AC_DEFINE(HAVE_STRUCT_TIMEZONE)
+AC_DEFINE(HAVE_STRUCT_TIMEZONE, 1,
+ [Define if \`struct timezone' is defined])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
@@ -1105,7 +1115,8 @@ dnl
AC_MSG_CHECKING(for st_blocks in struct stat)
AC_TRY_COMPILE([
#include <sys/stat.h>],[struct stat sb; sb.st_blocks=0;],
-AC_DEFINE(HAVE_STAT_ST_BLOCKS)
+AC_DEFINE(HAVE_STAT_ST_BLOCKS, 1,
+ [Define if \`struct stat' has the \`st_blocks' field])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
@@ -1117,25 +1128,29 @@ AC_CHECK_FUNCS(_scrsize ioctl)
AC_MSG_CHECKING(for struct videoconfig)
AC_TRY_COMPILE(,[struct videoconfig w; w.numtextcols=0;],
-AC_DEFINE(HAVE_STRUCT_VIDEOCONFIG)
+AC_DEFINE(HAVE_STRUCT_VIDEOCONFIG, 1,
+ [Define if \`struct videoconfig' is defined])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
AC_MSG_CHECKING(for struct text_info)
AC_TRY_COMPILE(,[struct text_info w; w.screenwidth=0;],
-AC_DEFINE(HAVE_STRUCT_TEXT_INFO)
+AC_DEFINE(HAVE_STRUCT_TEXT_INFO, 1,
+ [Define if \`struct text_info' is defined])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
AC_MSG_CHECKING(for TIOCGWINSZ)
AC_TRY_COMPILE([#include <sys/ioctl.h>],[int w=TIOCGWINSZ;],
-AC_DEFINE(HAVE_TIOCGWINSZ)
+AC_DEFINE(HAVE_TIOCGWINSZ, 1,
+ [Define if the ioctl TIOGWINSZ is defined])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
AC_MSG_CHECKING(for TIOCGGETD)
AC_TRY_COMPILE([#include <sys/ioctl.h>],[int w=TIOCGETD;],
-AC_DEFINE(HAVE_TIOCGETD)
+AC_DEFINE(HAVE_TIOCGETD, 1,
+ [Define if the ioctl TIOCGETD is defined])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
@@ -1155,13 +1170,15 @@ AC_C_INLINE
AC_MSG_CHECKING(for __attribute__ extension)
AC_TRY_COMPILE(,[int __attribute__((unused)) x],
- AC_DEFINE(HAVE_ATTRIBUTE)
+ AC_DEFINE(HAVE_ATTRIBUTE, 1,
+ [Define if the __attribute__(()) extension is present])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
AC_MSG_CHECKING(for __FUNCTION__ extension)
AC_TRY_COMPILE(,[(void)__FUNCTION__],
- AC_DEFINE(HAVE_FUNCTION)
+ AC_DEFINE(HAVE_FUNCTION, 1,
+ [Define if the compiler understand the __FUNCTION__ keyword])
AC_MSG_RESULT(yes),
AC_MSG_RESULT(no))
@@ -1195,7 +1212,8 @@ int main(void)
done)
AC_MSG_RESULT(%${hdf5_cv_printf_ll}d and %${hdf5_cv_printf_ll}u)
-AC_DEFINE_UNQUOTED(PRINTF_LL_WIDTH,"$hdf5_cv_printf_ll")
+AC_DEFINE_UNQUOTED(PRINTF_LL_WIDTH, "$hdf5_cv_printf_ll",
+ [Width for printf() for type \`long long' or \`__int64', us. \`ll'])
dnl ----------------------------------------------------------------------
dnl Check if malloc(0) returns valid pointer
@@ -1487,7 +1505,8 @@ dnl Print some other parallel information and do some sanity checks.
dnl
if test -n "$PARALLEL"; then
dnl We are building a parallel library
- AC_DEFINE(HAVE_PARALLEL)
+ AC_DEFINE(HAVE_PARALLEL, 1,
+ [Define if we have parallel support])
dnl Display what we found about running programs
AC_MSG_CHECKING(prefix for running on one processor)
@@ -1780,7 +1799,6 @@ dnl Don't worry about the C++ ifdef wrappers in the H5pubconf file, since
dnl 'H5_inline' isn't a C++ keyword.
cat >> src/H5config.h <<EOF
-/* inline is a keyword in C++. If this is a C++ compiler, undefine it */
#if defined(__cplusplus) && defined(inline)
#undef inline
#endif