summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-03 15:40:38 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-03 15:40:38 (GMT)
commit510daa2995533741ec47a41d42facd26a54b5b9c (patch)
treed0a1a18da5fc1a5d7868a68827d4aa062dede036 /configure.in
parentde2091c7cdd1eae33db4e9d4b6fdd1783462cb95 (diff)
downloadhdf5-510daa2995533741ec47a41d42facd26a54b5b9c.zip
hdf5-510daa2995533741ec47a41d42facd26a54b5b9c.tar.gz
hdf5-510daa2995533741ec47a41d42facd26a54b5b9c.tar.bz2
[svn-r15586] Description:
Changed the test for intrinsic Fortran function SIZEOF by using AC_TRY_RUN instead of AC_TRY_COMPILE.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 9c04f7a..32e46e9 100644
--- a/configure.in
+++ b/configure.in
@@ -389,8 +389,10 @@ dnl --------------------------------------------------------------------
dnl See if the fortran compiler supports the intrinsic function "SIZEOF"
AC_MSG_CHECKING([if Fortran compiler supports intrinsic SIZEOF])
- AC_TRY_COMPILE(,[
- i = sizeof(x)
+ AC_TRY_RUN([
+ PROGRAM main
+ i = sizeof(x)
+ END PROGRAM
], [AC_MSG_RESULT(yes)
HAVE_SIZEOF="yes"],
AC_MSG_RESULT(no))