summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-03-31 18:51:49 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-03-31 18:51:49 (GMT)
commit1c7d12a7699faad5283b53f6d95a1b7be59d99af (patch)
tree5ba77a36e2e18c3419cf2c3fcc6154dae8a9ceb1 /configure.in
parent92178e5fffb69d32d5a1f5781969a3c6b9bf9f35 (diff)
downloadhdf5-1c7d12a7699faad5283b53f6d95a1b7be59d99af.zip
hdf5-1c7d12a7699faad5283b53f6d95a1b7be59d99af.tar.gz
hdf5-1c7d12a7699faad5283b53f6d95a1b7be59d99af.tar.bz2
[svn-r12186] Purpose:
Bug fix Description: Made parallel fortran configuration happier on modi4 Solution: The old configure macro, AC_TRY_LINK, added a couple of extra lines to the Fortran test program which the new macro doesn't. Added those lines manually. Platforms tested: modi4, copper (change should affect only parallel fortran)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8f32823..2235b97 100644
--- a/configure.in
+++ b/configure.in
@@ -2161,9 +2161,11 @@ case "X-$enable_parallel" in
dnl Try link a simple MPI program. If fail, try again with -lmpi.
AC_LINK_IFELSE([
+ program main
include 'mpif.h'
integer:: ierr
- call mpi_file_open( ierr )],,
+ call mpi_file_open( ierr )
+ end],,
AC_CHECK_LIB(mpi, [
include 'mpif.h'
integer:: ierr
@@ -2173,9 +2175,11 @@ case "X-$enable_parallel" in
dnl -lmpio.
if test "X$PARALLEL" = "Xyes"; then
AC_LINK_IFELSE([
+ program main
include 'mpif.h'
integer:: ierr
- call mpi_file_open( ierr )],,
+ call mpi_file_open( ierr )
+ end],,
AC_CHECK_LIB(mpio, [
include 'mpif.h'
integer:: ierr