summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2010-05-04 16:35:11 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2010-05-04 16:35:11 (GMT)
commit7cb55dd05270a5c6df2e492c14490bc2ddd4dc41 (patch)
treed35975a058421107b1cd3d92f41e7dccec7a8040 /configure.in
parentf80d971c3b7add9517b15df7c62b38b45ba8643a (diff)
downloadhdf5-7cb55dd05270a5c6df2e492c14490bc2ddd4dc41.zip
hdf5-7cb55dd05270a5c6df2e492c14490bc2ddd4dc41.tar.gz
hdf5-7cb55dd05270a5c6df2e492c14490bc2ddd4dc41.tar.bz2
[svn-r18696] I added a macro definition if the system is Cygwin in configure.in. This macro is used to skip
the data conversion test from unsigned long long to long double. The GCC on Cygwin seems to have rounding problem when doing conversion from unsigned long long to long double (Please bug #1813). Tested on jam. I'll test it on Cygwin after this checkin.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 29118b4..605ba6c 100644
--- a/configure.in
+++ b/configure.in
@@ -961,6 +961,7 @@ dnl ----------------------------------------------------------------------
dnl Shared libraries are not currently supported under Cygwin.
case "`uname`" in
CYGWIN*)
+ AC_DEFINE([CYGWIN], [1], [Define a macro for Cygwin system])
if test "X${enable_shared}" = "Xyes"; then
echo ' warning: shared libraries are not supported on Cygwin!'
echo ' disabling shared libraries'