summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScott Wegner <swegner@hdfgroup.org>2008-02-18 14:05:47 (GMT)
committerScott Wegner <swegner@hdfgroup.org>2008-02-18 14:05:47 (GMT)
commitdee9447656a78e53342ec84eda9bd3a19be21920 (patch)
tree2ea5f5310d4415a775d71d8e5b1f5b1fb15613f5 /configure.in
parent50a758f887ae8940ba78a469c47ae63979767b81 (diff)
downloadhdf5-dee9447656a78e53342ec84eda9bd3a19be21920.zip
hdf5-dee9447656a78e53342ec84eda9bd3a19be21920.tar.gz
hdf5-dee9447656a78e53342ec84eda9bd3a19be21920.tar.bz2
[svn-r14595] Purpose: Patch the latest Cygwin's incompatibility with timzezone variable
Description: We discovered that there was a problem with the latest cygwin DLL, in that it doesn't recognize the global variable 'timezone'. This is a problem on cygwin's side, not ours. Instead, we avoid the problem in configure with a case statement. We didn't get this out in time for the release, but we can offer a patch instead. Tested: Cygwin on WinXP All changes are in a cygwin 'case' clause, so shouldn't affect other platforms
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 15 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 2c45d38..7461c56 100644
--- a/configure.in
+++ b/configure.in
@@ -1728,13 +1728,21 @@ AC_MSG_RESULT([no]))
dnl Check whether the global variable `timezone' is defined.
AC_MSG_CHECKING([for global timezone variable])
-AC_TRY_LINK([
-#include <sys/time.h>
-#include <time.h>], [timezone=0;],
-AC_DEFINE([HAVE_TIMEZONE], [1],
- [Define if `timezone' is a global variable])
-AC_MSG_RESULT([yes]),
-AC_MSG_RESULT([no]))
+
+case "`uname`" in
+ CYGWIN*)
+ AC_MSG_RESULT([disabled in CYGWIN])
+ ;;
+ *)
+ AC_TRY_LINK([
+ #include <sys/time.h>
+ #include <time.h>], [timezone=0;],
+ AC_DEFINE([HAVE_TIMEZONE], [1],
+ [Define if `timezone' is a global variable])
+ AC_MSG_RESULT([yes]),
+ AC_MSG_RESULT([no]))
+ ;;
+esac
dnl Check whether `struct timezone' is defined.
AC_STRUCT_TIMEZONE