summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2009-04-28 19:41:42 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2009-04-28 19:41:42 (GMT)
commit665f528813749ce6b1ce9afdf104262a65a4a2cd (patch)
tree5839f00d5537981ae08fad294dc46a7a9a0f4efd /configure.in
parent75a7a98214a0a408adff8b90b697682f10a4de77 (diff)
downloadhdf5-665f528813749ce6b1ce9afdf104262a65a4a2cd.zip
hdf5-665f528813749ce6b1ce9afdf104262a65a4a2cd.tar.gz
hdf5-665f528813749ce6b1ce9afdf104262a65a4a2cd.tar.bz2
[svn-r16875] Merged changes from the trunk into the branch:
svn merge -r16602:16869 https://svn.hdfgroup.uiuc.edu/hdf5/trunk Tested on: smirom
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0fa7a1a..47d167f 100644
--- a/configure.in
+++ b/configure.in
@@ -26,7 +26,7 @@ dnl
dnl NOTE: Don't forget to change the version number here when we do a
dnl release!!!
dnl
-AC_INIT([HDF5], [1.9.36], [help@hdfgroup.org])
+AC_INIT([HDF5], [1.9.39], [help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AM_CONFIG_HEADER([src/H5config.h])
@@ -1306,6 +1306,7 @@ AC_C_BIGENDIAN
AC_CHECK_SIZEOF([char], [1])
AC_CHECK_SIZEOF([short], [2])
AC_CHECK_SIZEOF([int], [4])
+AC_CHECK_SIZEOF([unsigned], [4])
AC_CHECK_SIZEOF([long], [4])
AC_CHECK_SIZEOF([long long], [8])
AC_CHECK_SIZEOF([__int64], [8])
@@ -3796,6 +3797,25 @@ esac
dnl ----------------------------------------------------------------------
+dnl Enable embedded library information
+dnl
+AC_MSG_CHECKING([Whether to have library information embedded in the executables])
+AC_ARG_ENABLE([embedded-libinfo],
+ [AC_HELP_STRING([--enable-embedded-libinfo],
+ [Enable embedded library information [default=yes]])],
+ [enable_embedded_libinfo=$enableval],
+ [enable_embedded_libinfo=yes])
+
+ if test "${enable_embedded_libinfo}" = "yes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_EMBEDDED_LIBINFO], [1],
+ [Define if library information should be embedded in the executables])
+ else
+ AC_MSG_RESULT([no])
+ fi
+
+
+dnl ----------------------------------------------------------------------
dnl Check if pointer alignments are enforced
dnl
AC_MSG_CHECKING([if alignment restrictions are strictly enforced])