summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2009-05-11 17:37:32 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2009-05-11 17:37:32 (GMT)
commit7c506b2e1e79c510411be73f9a12550ecea0a077 (patch)
tree51e7498e6d678f9bcd2c782d0aabe9765031ec1e /configure.in
parentffed17cb9cd8460dc08affa87cabc34effd12746 (diff)
downloadhdf5-7c506b2e1e79c510411be73f9a12550ecea0a077.zip
hdf5-7c506b2e1e79c510411be73f9a12550ecea0a077.tar.gz
hdf5-7c506b2e1e79c510411be73f9a12550ecea0a077.tar.bz2
[svn-r16936] Merged changes from the trunk into the branch:
svn merge -r16869:16933 https://svn.hdfgroup.uiuc.edu/hdf5/trunk Tested: smirom
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 47d167f..e0e6a91 100644
--- a/configure.in
+++ b/configure.in
@@ -2468,6 +2468,19 @@ case "X-$enable_parallel" in
fi
dnl Set RUNPARALLEL to mpirun if not set yet.
+ dnl Check for building on Cray if RUNPARALLEL is not yet set by checking
+ dnl for 'aprun' command (which is the parallel job launcher, like mpirun).
+ if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
+ dnl Find the path where aprun is located.
+ for path in `echo $PATH | ${TR} ":" " "`; do
+ if test -x $path/aprun; then
+ RUNPARALLEL="aprun -q -n \$\${NPROCS:=3}"
+ break;
+ fi
+ done
+ fi
+
+ dnl Set RUNPARALLEL to mpirun if not set yet.
if test "X$PARALLEL" = "Xyes" -a -z "$RUNPARALLEL"; then
RUNPARALLEL="mpirun -np \$\${NPROCS:=3}"
fi