summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2011-08-23 21:37:00 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2011-08-23 21:37:00 (GMT)
commitdfd8d5c9fea6f4abcf3752f20e580a0678f0ecb3 (patch)
tree3009a5d0a437bf4e0829c404e402a6a186443e0e /configure.in
parentbe904e0eae88d92d8014c879e0464f3dba144316 (diff)
downloadhdf5-dfd8d5c9fea6f4abcf3752f20e580a0678f0ecb3.zip
hdf5-dfd8d5c9fea6f4abcf3752f20e580a0678f0ecb3.tar.gz
hdf5-dfd8d5c9fea6f4abcf3752f20e580a0678f0ecb3.tar.bz2
[svn-r21304] Backed out bad Fortran test.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index f245818..2d632e2 100644
--- a/configure.in
+++ b/configure.in
@@ -529,10 +529,11 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_MSG_CHECKING([if Fortran compiler supports ISO_C_BINDING module])
- AC_COMPILE_IFELSE(AC_LANG_PROGRAM([],[USE iso_c_binding]),
- [AC_MSG_RESULT(yes) HAVE_ISO_C_BINDING="yes"],
- AC_MSG_RESULT(no)
- )
+ AC_TRY_COMPILE(,[
+ USE iso_c_binding
+ ], [AC_MSG_RESULT(yes)
+ HAVE_ISO_C_BINDING="yes"],
+ AC_MSG_RESULT(no))
if test "X$HAVE_ISO_C_BINDING" = "Xno"; then
AC_MSG_ERROR([Fortran compiler does not have ISO_C_BINDING; unsupported Fortran 2003 compiler, remove --enable-fortran2003])