summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2006-05-19 12:22:07 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2006-05-19 12:22:07 (GMT)
commit56c0a0f9930c0a7d5cfa61ffc0872bcc0d4bee29 (patch)
tree2c18b57ef03c569274255f31e7bf593fd3c228e3 /configure.in
parent698f38c1fedfb487c5e2df274730c3df59ef8527 (diff)
downloadhdf5-56c0a0f9930c0a7d5cfa61ffc0872bcc0d4bee29.zip
hdf5-56c0a0f9930c0a7d5cfa61ffc0872bcc0d4bee29.tar.gz
hdf5-56c0a0f9930c0a7d5cfa61ffc0872bcc0d4bee29.tar.bz2
[svn-r12358] Purpose:
Bug fix. Description: The ${TR}, though avoid the error, is inconvenient. It is needed because configure.in use the char range in the style of 'a-z'. The other style of '[a-z]' is more commonly accepted by all tr but autoconf tends to strip away [], making the syntax rather clumsy. Solution: Learned from autoconf that it avoids the use of character range by just spell all the letters out. Changed our tr commands to use those variables defined by autoconf. Also removed the definition of ${TR} since it will cause inconsistancy when autoconf also use plain 'tr' in its generated code. The Makefile.in are changed because the elimination of ${TR} from configure triggered its removal from all Makefil.in. That is okay because ${TR} is not used at all in Makefile. Platforms tested: h5committested. (sol failed to connected). also tested in shanti using both /usr/ucb/tr and /bin/tr (the bad one before.) Misc. update: Updated both INSTALL and RELEASE files.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 11 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 54800fb..5b77514 100644
--- a/configure.in
+++ b/configure.in
@@ -112,25 +112,16 @@ set >&AS_MESSAGE_LOG_FD
AC_MSG_RESULT([done])
dnl ----------------------------------------------------------------------
-dnl Some platforms have broken tr, basename, and/or xargs programs. Check
+dnl Some platforms have broken basename, and/or xargs programs. Check
dnl that it actually does what it's supposed to do. Catch this early
-dnl since configure relies upon tr heavily and there's no use continuing
+dnl since configure relies upon them heavily and there's no use continuing
dnl if it's broken.
dnl
-dnl If the TR variable is set, use it as tr.
-AC_SUBST([TR])
-if test "X${TR}" = "X"; then
- TR=tr
-fi
-
-AC_MSG_CHECKING([if tr works])
-TR_TEST="`echo Test | ${TR} 'a-z,' 'A-Z '`"
-if test "X${TR_TEST}" != "XTEST"; then
- AC_MSG_ERROR([tr program ${TR} doesn't work])
-else
- AC_MSG_RESULT([yes])
-fi
+dnl Avoid depending upon Character Ranges.
+dnl These are defined by autoconf.
+dnl as_cr_letters='abcdefghijklmnopqrstuvwxyz'
+dnl as_cr_LETTERS='ABCDEFGHIJKLMNOPQRSTUVWXYZ'
AC_MSG_CHECKING([if basename works])
BASENAME_TEST="`basename /foo/bar/baz/qux/basename_works`"
@@ -1781,7 +1772,7 @@ case "X-$DEBUG_PKG" in
esac
if test -n "$DEBUG_PKG"; then
- for pkg in `echo $DEBUG_PKG | ${TR} 'a-z,' 'A-Z '`; do
+ for pkg in `echo $DEBUG_PKG | tr ${as_cr_letters}',' ${as_cr_LETTERS}' '`; do
H5_CPPFLAGS="$H5_CPPFLAGS -DH5${pkg}_DEBUG"
done
fi
@@ -1962,7 +1953,7 @@ case "$CC_BASENAME" in
if (echo $cmd | grep / >/dev/null); then
path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH | ${TR} : ' '`; do
+ for path in `echo $PATH | tr : ' '`; do
if test -x $path/$cmd; then
break
fi
@@ -1993,7 +1984,7 @@ case "$CC_BASENAME" in
if (echo $cmd | grep / >/dev/null); then
path="`echo $cmd | sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH | ${TR} : ' '`; do
+ for path in `echo $PATH | tr : ' '`; do
if test -x $path/$cmd; then
break
fi
@@ -2051,7 +2042,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
if (echo $cmd |grep / >/dev/null); then
path="`echo $cmd |sed 's/\(.*\)\/.*$/\1/'`"
else
- for path in `echo $PATH |tr : ' '`; do
+ for path in `echo $PATH | tr : ' '`; do
if test -x $path/$cmd; then
break;
fi
@@ -2425,7 +2416,7 @@ case "X-$FILTERS" in
esac
if test -n "$FILTERS"; then
- for filter in `echo $FILTERS | ${TR} 'a-z,' 'A-Z '`; do
+ for filter in `echo $FILTERS | tr ${as_cr_letters}',' ${as_cr_LETTERS}' '`; do
dnl ------------------------------------------------------------------
dnl Have to use separate 'if' construct for each filter, so that
dnl autoheader can detect the AC_DEFINE for each one...